Scripto Unknown login error: Failed

Hi everyone,

I’ve seen that there are a few posts on this topic but as they’re all a few years old and none of those fixes are working, I thought I’d ask again!

I’ve installed Scripto and MediaWiki correctly, but when I try to log in I get “Unknown login error: Failed”. I’ve changed the settings so that anonymous users can contribute and that works, but I can’t sign in.

I’ve seen info about changing the MediaWiki cookie prefix field but I’ve tried every variation (my database name is dickenss_mw1 and I’ve tried dickenss_mw1, dickenss_mw1_, dickenss_mw1_mw, dickenss_mw1_mw_) and it still isn’t working. Is there something else obvious it might be?

It’s Scripto 2.4 and MediaWiki 1.35.1 (and Omeka 2.7.1).

Thanks for any help you can offer!

That’s odd. I cannot reproduce the error when using identical versions of the software. Are you sure you’re using the right credentials? Are your MediaWiki tables in a shared database or do they have a prefix? If so, try <dbname>_<dbprefix> as your cookie prefix. The logic for cookie prefix is here.

Thanks for replying! It’s still not working, but honestly my technical know-how is pretty low so I may be doing something simple wrong. Are the steps below what should work?

I went to LocalSettings.php in the wiki directory and looked for $wgDBname and $wgDBprefix. The values are:
$wgDBname = “dickenss_mw1”;
and
$wgDBprefix = “mw_”;

So what I should be entering in the field in the MediaWiki cookie prefix field on the Scripto plugin page in the Omeka dashboard is:

dickenss_mw1_mw_

Is that right?

ETA: yes, I checked my MediaWiki login and password so those are definitely correct.

I would expect dickenss_mw1_mw_ or perhaps dickenss_mw1_mw to work. Look for $wgSharedDB and $wgSharedPrefix. If they exist, try <wgSharedDB>_<wgSharedPrefix>. Otherwise, there’s something else wrong. You mention that you “changed the settings so that anonymous users can contribute.” What settings did you change?

There are no $wgSharedDB and $wgSharedPrefix fields in the file, and it still doesn’t work with dickenss_mw1_mw_ or dickenss_mw1_mw

I changed the two $wgGroupPermissions at the bottom (edit and createpage) to true (this was only after getting the above error, in an effort to make it useable even without signing in)

Can you successfully log in to your actual MediaWiki site?

Try logging in after removing all custom changes that you made to LocalSettings.php.

Unfortunately, I’m running out of solutions.