Resources tab not adding items to site


I’m working on an install that has close to 7,000 items. We recently upgraded from 2.1.2 to 3.0.1. There is one site for this install, and I’ve attempted to add all the items to the site in the resources tab. I’ve tried both the add and replace searches, but neither have added any of the items to the site. When I check the jobs tab, the status is listed as starting, but there is no log for me to check (we have logging enabled).

I would appreciate any help with this. I’m probably doing something wrong but can’t put my finger on what it might be.

Thanks very much.

Do any other jobs work for you on this installation? Like imports or batch edits?

Being stuck on “Starting” tends to mean the job failed immediately, before even getting to start.

Hi John -
I just tried a CSV import and that didn’t work, either. It’s not appearing in the Past Imports section of the CSV Import module and in the Jobs tab it is stuck on “Starting” just like the others.
I appreciate your response!

So, your background jobs are just totally broken then. It’s tough to give advice on fixing this because the job just breaks immediately and doesn’t log any errors or anything like that.

Did you change anything else about your server when you upgraded Omeka S? Or have you not tried to run any jobs for a while, so they could have been broken for a while? The Jobs list should make that clear, when the last successful job was run.

The usual advice applies, make sure that if necessary the path to PHP CLI is configured correctly in config/local.config.php. If it becomes necessary, it’s possible to switch the jobs to run synchronously in the config file, which will avoid this problem with the item assignments.

Synchronous jobs just run during a web request, which means they’re not really suitable for long-running processes; this is fine for site item assignment which is quite fast, but would be an issue possibly for something like an import.

It was the PHP CLI configuration. Thank you!

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.