Recently added items not searchable

I am new to an institution that is using Omeka to showcase their digital collections. They showed me that the when they try and search some of the recently added items, they do not appear in the search results. I want to check if the searching function is running properly and trying to troubleshoot if this is Omeka or something to do with the way the records are set up.

Is the site publicly available? Some more detail about what’s not working would be helpful also.

The site is public and I think we figured out that the titles of the items had an underscore, so the title was “archives_keanu” and once we removed the underscore it seemed to read it. Does this sound correct? Does the search get tripped up by underscores?

Because over 800 of these files have underscores in the titles, I am wondering if there is a way to use Bluk editor to delete all the underscores in the titles. Please let me know if that is possible with Bulk Editor and how to proceed.

I was able to use the Bulk Editor to remove the underscores from the titles, but I just checked and when I search the names they are still not showing up in the results. The titles are now structured like this “HMCSL - HEA Archive - Auwaa.pdf” but when I search “Auwaa” I don’t get any hits.

Please help, any and all tips would be helpful. I feel more confident in using Bulk editor so hopefully the fix is simple.

One thing to try is the “Reindex” search option.

The bulk editor probably just edits the metadata directly and doesn’t also update the search index.

Reindexing worked! Thank you all so much!