Plugin compatibility with Omeka 2.6?


#1

Huge thanks and congrats to everyone who contributed to the 2.6 release! I’m excited to upgrade my instance, but I want to make sure I know what I’m doing. :slight_smile:

I’ve backed up my database, of course, but I’m wondering about plugin compatibility. I realize this is generally verified case-by-case by plugin developers, but I figured I’d check in here to see if anyone has run into any issues after upgrading to 2.6.

I’m running the following:

  • Archive Repertory
  • Bulk Metadata Editor
  • CollectionTree
  • CSV Import
  • Derivative Images
  • Dublin Core Extended
  • Guest User
  • Hide Elements
  • SimpleContactForm
  • Simple Vocab Plus

Thanks much,
Jess


#2

From the release notes:

Updated versions of ExhibitBuilder and SimplePages are bundled with the release, but others must be updated, including Commenting, Contribution, Posters, SimpleContactForm, and UserProfiles

Those mentioned plugins all should be updated due to changes in TinyMCE (so, SImpleContactForm for you). As far as I’m aware, those are the only ones that should have a change in compatibility from 2.6, though any other plugin that uses a WYSIWYG editor could also.


#3

Ah, perfect — thank you, @jflatnes! Exactly what I was looking for.