PDF zoomed out view

I did a search but no one has written about this issue.

I’m familiar with the PDF Embed and have used it successfully in the past with single page documents as well as multipage. I’m preparing to upload about 1000 PDF’s online and i noticed that when i did a test, the initial “view” on the item page is a zoomed out view. In the past, the PDF would display “fit to width”" within the iFrame.

I initially thought it was a PDF issue during conversion, but i didnt’ change my workflow, so i’m not sure why it is happening? I just upgraded to the newer PDF Embed 1.2.0 to see if it would help, but it didn’t.

I looked at my old “PDF” items and they are displaying correctly (“fit to width”). The new uploaded materials are zoomed out (to the max)

I checked the code and do you think it needs editing?

‘’,
$view->escapeHtml($media->originalUrl())

This would be strange since my other files are displaying Fit Width?

The default zoom level is stored in the pdf at the time of writing, so I suspect there is some setting you can change when you process them originally.

Try opening them as pdf outside of the embed (in the browser or with a viewer) and you should see the difference.

You can, however, force the zoom on the pdf browser to fit to width, by appending #view=FitH to the src, like, filename.pdf#view=FitH.

See this question on StackOverflow for details.

But honestly, if you have generated the pdf yourself, I would first doublecheck the original workflow so that you have all the pdfs (the old and the new ones) with the same default zoom.

thank you for the reply! i was going to edit the source code as a last resort. i figured it could’ve been a PDF setting since i was using another workstation—my office desktop probably had the fit width setting standard.

Thanks again!

1 Like