Pb with iiif upload in back-office

Hello
Since this morning, I can’t upload IIIF ressource in omeka-S admin.
It worked fine before.

The different trys that I made are :

It seems that my iiif server works fine : is showed here https://api.nakala.fr/iiif/10.34847/nkl.c7cfsx78/e98dee21f6faedd8e7e654e62ba51bf06745d17a/full/600,600/180/default.jpg

If I try to upload a simple image (from my harddrive), it works fine…

SeaDragon works because the old images is showed…

So ! I haven’t no idea to fix it :
Have you got some help for me ?

I work with Omeka-S 2.1.2
PHP Version 7.3.27

Later… I note it works with an other server, for exemple https://gallica.bnf.fr/iiif/ark:/12148/btv1b90017179/f15/info.json

I think my pb is the IIIF server’s upgrade from v2 to v3.

Really, I would like so much be able to hack Omeka-S 2.1 on order to work with IIIF 3.0.
I upgrade Seadragon.
And I’m working on the Ingester/IIIF.php file, but it still doesn’t work :\

Thx for reading…

It seems to work with upgrade of seadragon and this minimal fix : https://github.com/omeka/omeka-s/pull/1585/commits/3e108cebb3133d99d18f512af6f4fc98fed12fe1

Yeah, it’s the IIIF Image API v3 being used as the issue. Backporting the updates to support v3 is possible as you’ve done, or just upgrading Omeka S will do it.

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.