Omeka version necessary for Neatline

Hi there,
I am looking to make use of Omeka with the Neatline plugin for a digital project, and am wondering whether Neatline is compatible with the free ‘Trial’ version of Omeka or which level of the paid subscription I would need to have to be able to use that plugin? Additionally, does Neatline work with Omeka.net or only with the downloaded version of Omeka Classic?
Many thanks,
Mary

Neatline is not available as a plugin on the Omeka.net infrastructure.

It appears that the last time the main Neatline plugin was updated was May 2021, which means it might not be styled to run with the most recent version of Omeka Classic, but might be okay with v.2.8.