Omeka-S v2.0.2 with IIIF and Mirador support

As @Daniel_KM says, please use this information at your own risk.

The recent v2 of Omeka-S requires modules to be updated, and so at the moment there are a good number of very useful modules that are not officially updated.

Per the release note on required module changes https://forum.omeka.org/t/omeka-s-2-0-0-release-upcoming-required-change-for-modules/9098 and with further input from @jflatnes, some of the community’s modules out there do not require anything other than a variable upgrade.

Modules that don’t add stuff to the API (no src/Api folder) and don’t hook into the API (no “api” events in Module.php) generally don’t need any changes and can just have the omeka_version_constraint in module.ini edited to tack on || ^2.0.0

Again, feel free to test and experiment but if you don’t know what you are doing, you may not want to apply this “patch” to production systems.

IN MY TESTING, I was able to apply this patch to both Omeka-S-module-Mirador release v3.1.1 https://github.com/Daniel-KM/Omeka-S-module-Mirador/releases/tag/3.1.1 and to Omeka-S-module-IiifServer release v3.5.15-beta https://github.com/Daniel-KM/Omeka-S-module-IiifServer/releases/tag/3.5.15-beta without issue.

ALSO IN MY TESTING, unlike with the IIIF support and modules for Omeka Classic, which does not necessarily work “out of the box” for beginners, experimenters, and non-techies - with the latest version of Omeka-S + Omeka-S-module-IiifServer + Omeka-S-module-Mirador, things work “out of the box” with zero customization of default settings.

I have not yet tried Omeka-S-module-UniversalViewer but assume it would be the same result.

One caveat so far - and I am not yet a Mirador expert, especially with the older v2 just being replaced with the new v3 - as of right now, the annotation module does not function / load as it does in the projectmirador.org demo.

After some code diff, tracing, and experimentation, I was able to get annotation toolbar turned on in the Mirador module.

EDIT
/omeka-s/modules/Mirador/src/View/Helper/Mirador.php

ADD

$config += [
   'annotationEndpoint' => ['name' => "Local Storage", 'module' => "LocalStorageEndpoint"]
];

AFTER

   $siteConfig = json_decode($siteConfig, true) ?: [];
2 Likes

Yes, I’m updating my modules for Omeka 2. Mirador is released, but not yet module IIIF server.

I’ll extend @benbakelaar’s comment to say that I made the same simple tweak to Universal Viewer 3.6.0, changing
omeka_version_constraint = "^1.2.0"
to
omeka_version_constraint = "^1.2.0 || ^2.0.0"
and it seemed to Just Work.

Many thanks to @Daniel_KM for the writing and maintenance of these modules.

They are updated on github and omeka.org.

1 Like