Omeka S HTML block stripping out form tags

Does anyone know why HTML form tags inserted into the Source window within an HTML block element on a site page are being stripped out? I am not using the HTMLPurifier option. I’m guessing the issue lies with CKEditor.

I have found the CKEditor config and config.allowedContent = true; seems correct. Do I need to add a custom config setting of some sort to the CKEditor config or is something else on, elsewhere?

many thanks

Bump!

I’m having this same issue.

Mark

I think I’ve finally narrowed this down: it has to do with the “minimal” editor we’re using: it basically just doesn’t support <form> as content, regardless of whether it’s set to be stripped out (because the editor element is already inside a form, and nested forms aren’t allowed).

I don’t think there’s a way around this other than switching to the “heavy” editor… we don’t generally want to do that just because it takes up more space on an already-crowded page, but maybe we could make it an option of some kind…