Omeka Classic running Neatline and Neatlight

Hi guys, I’m new to the forum and just wondered if there are any plans to update Omeka/neatline and neatlight for compatibility with PHP 7.2. I built an omeka classic install recently with neatline, neatlight and neatline waypoints in order to build a map exhibit with soundfiles.

It worked perfectly and then became inaccessible. Hosting provider told me that they upgraded servers to PHP 7.2 which broke my omeka install or conflicted with one of the aforementioned plugins or both.

The provider rolled back the site to PHP 7 and they’re still investigating the problem-as the site still isn’t loading.

Has anyone else encountered similar? and will Omeka and the plugins mentioned be updated to work with PHP 7.2? I’m not a tech person btw, and know nothing about PHP apart from what the hosting company have told me.



Hi D,

Thanks for giving us a heads up on this issue. I’ve created a github issue for our developers so that we can work this into our workflows. You can track that issue by going to

I’ll update here when our developers have had time to look at this and determine a timeline for the work.


1 Like

Thanks for that Ronda, much appreciated. Like I didn’t quite make clear in the post that it’s the whole site that is now broken, and the neatline exhibit, so I don’t know wherein the problem lies.
Thanks for your quick reponse. I’m planning another site soon, and as version 7 of PHP is no longer supported from Dec, it’s good to know there are plans in place. Thanks again, D

As for Omeka Classic itself, the latest version has no issues with 7.2.

I’m not sure PHP 7.2 is really the issue here since you seem to be saying they moved you back to an older PHP version and the problem persists.

It’s difficult to say more of substance without more information.

The hosting company reverted that install to php 7.0 which seemed to fix the problem. I’m not a developer so I can’t say much else on that, but I can ask them for an error log or something which might help. All I can say is that I installed Omega classic in July, along with the aforementioned plugins, everything worked fine, then the site broke, the hosting company said they had upgraded servers to 7.2, they reverted the install and the site came back. But I’ll ask them for specifics. They weren’t able to tell me yesterday , exactly where the conflict was, but I’ll ask.

spoke to the hosting provider. They can’t point exactly to the problem, it’s looking more likely to be one of the plugins. I see there is a new release of Neatline (July 29th) which came out after I built my site. I’m hesitant to install that release in case I break the site again.

If you (or they) have details like an error message or log, that would be helpful.

If you were running an older version of Omeka, it’s possible an upgrade of PHP on the server could have caused an error.

Unfortunately there is no error log. It was not turned on for the install.

Then version of Omeka is the latest release as far as I am aware. Version 2.7. It’s neatline that was updated after I installed the site. (the site is still running the pre- July 29 version of neatline) The other plugins are still on the current version.

I installed the site on the 4th July using Omeka 2.7, the pre- July 29th update of Neatline and the then current and same now versions of Neatlight, and Neatline Waypoints. The only other active plugins were exhibit builder and simple pages.

Update: I just deactivated simple pages and the site broke, waiting to hear from the hosting company.