Omeka can't find my new account or site, Strict Standards errors

I managed to install Omeka yesterday to a Linux server (1and1), but today the page I get has two error messages and doesn’t recognize my log-in. Not really sure how to move forward. Thanks!

Errors are:
Strict Standards: Declaration of Omeka_Acl::addRole() should be compatible with Zend_Acl::addRole($role, $parents = NULL) in /homepages/10/d634665168/htdocs/Ledbetter/omeka-1.2.1/application/libraries/Omeka/Acl.php on line 18

Strict Standards: Declaration of Omeka_View_Helper_Url::url() should be compatible with Zend_View_Helper_Url::url(array $urlOptions = Array, $name = NULL, $reset = false, $encode = true) in /homepages/10/d634665168/htdocs/Ledbetter/omeka-1.2.1/application/helpers/Url.php on line 11

That looks like you’re trying to install a very old version of Omeka. You’ll want to use the current version, 2.4.1

Hello. Do you recommend using this version (2.4.1) as the most stable one? :slight_smile: Thanks in advance for your answer!

yep. that’s the one to use

Thanks! Yes, for some reason it defaulted to that, not sure why – I fixed it.