Omeka 2 importer - php path error

Dear all, I’m new to Omeka and I’m trying to import contents from Omeka.net to Omeka S, using Omeka 2 Importer. I enabled the API and API key in omeka.net and started the job that gave me this error in the job log:
2021-11-25T15:53:47+00:00 ERR (3): Command “command -v ‘php’” failed with status code 1.
2021-11-25T15:53:47+00:00 ERR (3): Omeka\Job\Exception\RuntimeException: PHP-CLI error: cannot determine path to PHP. in /web/htdocs/www.rib-gidif.org/home/application/src/Job/DispatchStrategy/PhpCli.php:68

Looking on this error in teh forum, I seemed to understand that I needed to modify the local.config.php file with the path to php (/php/bin/php provided by the aruba hosting service), I did this modification but Omeka S no longer worked , displaying a blank page after Sign In. I restored the original local.config.php file, Omeka S works, but the import problem is not solved.
I will be very grateful to you for any suggestions you may want to give me.

You do need to set the php path, as indicated in the user manual (Configuration Options - Omeka S User Manual) but you might have to check with your host to discover what that path should be.

Thank you Sharon, I did it, but I omitted to delimited the php path with single quotation marks, using them everything worked fine and I have been able to import the omeka.net site content.

1 Like