Omeka 2.5, Reclaim-hosted, ImageMagick

I’m not having any luck getting images to show up instead of thumbnail placeholders on my Omeka 2.5 site. Reclaim says that /usr/bin is the correct path to select for ImageMagick, but it doesn’t seem to do anything (e.g., when I try uploading something else after setting that). I’m mostly trying to use the YouTube Import plugin, and such an import always shows a file that I can click on, but the home page, etc. always just shows the placeholder. I don’t even get a thumbnail when I download a similar file and upload it separately into the item. I tried enabling fileDerivatives.strategy = “Omeka_File_Derivative_Strategy_Imagick” in the config.ini file, but that also didn’t work. Help!

Did you try:

or CSV Import not functioning on Reclaim Hosting install of Omeka

I don’t see a config/local.config.php file.

Looks like a difference between Omeka S and Omeka 2.5. You’ll want to look in application/config/config.ini for the line background.php.path = "" and fill in the correct path on Reclaim.

/usr/bin is what is supposed to work, according to Reclaim info and according to what Omeka says is working. But it just simply doesn’t work. I’ll try any one further suggestion, and if that doesn’t work, I will have to abandon Omeka.

I have a site at reclaim and i don’t set anything to the background path:

background.php.path = ""

In fact, I didn’t change anything in the original config.ini (copy from config.ini.dist) and it works fine.

I’m getting the YouTube Import plugin to work, but I cannot get any thumbnails to appear. I’ve tried setting config.ini’s background.php.path to “/usr/local/bin/php” and to “/usr/bin/php-cli,” I’ve set ImageMagick’s location to /usr/bin (which claims to work), I’ve tried fileDerivatives.strategy = “Omeka_File_Derivative_Strategy_Imagick,” and I’ve tried the Derivative Images plugin (which just errors). When I re-import something, no thumbnail appears, even though the link to a jpeg does appear. So, none of these things seem to do anything, in terms of actually displaying the jpeg. It just shows the fallback image. If I can’t get something as basic as item thumbnails to work, then I’m afraid I will have to abandon Omeka.

I merged your two topics just for simplicity’s sake (though merging isn’t really all that useful, I now see…)

The simplest piece of troubleshooting information would be this: do thumbnails get created normally if you just upload a “regular” file directly, like a JPEG? Taking YouTube Import out of the equation.

That should be working if you’ve got an ImageMagick path that reports “Works” in the settings page and you otherwise leave all the settings at defaults (so no “Imagick” strategy in the config.ini file). If it’s not, the typical cause is a server configuaration problem (i.e., an issue on Reclaim’s end of things).

Just catching this thread. I believe @dbowman might not be running Omeka with us anymore but for others considering it, I believe anything involving video that requires thumbnail generation needs not just ImageMagick but also ffmpeg on the server. This is not something we typically support on shared hosting due to the resource intensive nature of it, however we do have at least one server where we were able to set it up for folks and we’re happy to help when we can.

Also I’ll steal this opportunity since it might come up in search results to point to two relevant documents related to ImageMagic and PHP-cli paths specifically on Reclaim since there were a few thrown around here:

Setting the PHP-CLI path on Reclaim Hosting

Setting the ImageMagick path on Reclaim Hosting

Hi Tim. So, if I reinstall Omeka on Reclaim, you’ll be able to help me get the thumbnail images working, right? Thanks.

I’m certainly willing to look at it with you. I can’t speak specifically to the YouTube import plugin to know if ffmpeg is the culprit here but it seems awfully similar to the issue of video uploads not getting thumbnails that we worked with CHNM on and that ended up being the fix. I’ll follow up with you directly via support ticket and we’ll go from there.

HI again Tim. I just reinstalled Omeka on Reclaim, but now I can’t even get to the admin page. It just gives me a completely generic error: “Omeka has encountered an error.” Help!

I’m not really sure what to do. I’m trying to get an Omeka install working again on Reclaim, but I can’t even get to the admin page now. I just get the incredibly-non-informative error: “Omeka has encountered an error” at

I edited your .htaccess file to turn on error logging based on this Can you try now and report the full error? We just get a login page at that link so I’m assuming the error requires being logged in to see.

Omeka has encountered an error

The session has already been started. The session id must be set first.

exception ‘Zend_Session_Exception’ with message ‘The session has already been started. The session id must be set first.’ in /home/musichis/public_html/application/libraries/Zend/Session.php:667
Stack trace:
#0 /home/musichis/public_html/application/libraries/Zend/Session.php(426): Zend_Session::setId(‘b735f6a58098e8d…’)
#1 /home/musichis/public_html/application/libraries/Zend/Session/Namespace.php(143): Zend_Session::start(true)
#2 /home/musichis/public_html/application/libraries/Omeka/Controller/Plugin/Admin.php(74): Zend_Session_Namespace->__construct()
#3 /home/musichis/public_html/application/libraries/Zend/Controller/Plugin/Broker.php(309): Omeka_Controller_Plugin_Admin->preDispatch(Object(Zend_Controller_Request_Http))
#4 /home/musichis/public_html/application/libraries/Zend/Controller/Front.php(941): Zend_Controller_Plugin_Broker->preDispatch(Object(Zend_Controller_Request_Http))
#5 /home/musichis/public_html/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(105): Zend_Controller_Front->dispatch()
#6 /home/musichis/public_html/application/libraries/Zend/Application.php(384): Zend_Application_Bootstrap_Bootstrap->run()
#7 /home/musichis/public_html/application/libraries/Omeka/Application.php(77): Zend_Application->run()
#8 /home/musichis/public_html/admin/index.php(28): Omeka_Application->run()
#9 {main}

Hmmm, that’s a new one for me so I may have to defer to the fine folks in the forum. Only thing I could think is to try clearing your browser cache to see if that might help

It has something to do with Chrome, even though I cleared its cache, etc. I opened the admin URL with MS Edge, and it worked okay.

This does sound like a browser cache issue, both from the error messages you posted and from the difference when you switched browsers. Plus, I got to okay, though that’s not the admin login.

“fine folks in the forum” is clearly the new “fair field full of folk”.