OHMS viewer not appearing

Hello, we are using Omeka Classic Version 2.5.1 We recently worked on installing the OHMS Viewer. We’ve had some issues setting it up and would like some clarification.

1.) OHMS Viewer is a separate application from Omeka, but OHMSImport and OHMS Object are plugins available under Omeka. Is this correct?

2.) We set up OHMS Viewer under our Omeka document root in Apache2 which is /var/www/html/collections/ (this defaults to https://archives.uwp.edu) so the directory for OHMS Viewer is /var/www/html/collections/ohms-viewer. But Apache2 doesn’t appear to be recognizing the new directory. It has full permissions on ohms-viewer directory. Do we need to setup a separate virtual host for OHMS Viewer? Or is this a permissions issue? Are there additional php modules that need to be installed for OHMS Viewer to work?

Omeka is set up to want to control all the URLs “underneath” its top directory, so usually just making a subdirectory and putting files there won’t work.

The simple option is to have Omeka and OHMS Viewer live in side-by-side directories, but this would add an extra level to the Omeka path and you’d probably have to figure out redirecting from the site’s root URL… probably not ideal.

You can make this “directory inside Omeka” setup work, and maybe that’s the best option here. Try adding a file called .htaccess (the period at the front is important) inside your ohms-viewer folder, and put the following line as the contents of that file:

RewriteEngine Off

That should let you access the viewer rather than seeing a 404 page from Omeka.

It worked! Thanks so much. https://archives.uwp.edu/ohms-viewer/render.php?cachefile=UWPMC011_01.xml
Melissa