Not getting Thumbnail image on new file upload

We see the thumbnail on existing entries but when we upload a new file, it just shows the placeholder. We can eventually get to the actual photo but we want to see the thumbnail. I have implemented fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_Imagick” on a test server but still no thumbnail. Not sure what I am missing.

So, this screenshot is from the server set up to use “Imagick,” or not? Or you’re saying the results are the same for either.

My basic question would be: is this a problem you’re currently having with all images, or just with the particular ones you’re dealing with? In other words, can you re-upload the image shown at the bottom with a working thumbnail and still get a thumbnail out of it, or does it too now show the placeholder instead?

If it’s not working for all uploads, it’s usually something fairly simple like ImageMagick not being installed or there being some issue similar to that. If some files work and others do not, it can be a little more complex: there could be an issue with the files themselves, or a more subtle problem with ImageMagick (like the install on the server doesn’t support a particular format of image).

On the live server, I have had trouble installing ImageMagick but I am working on that. There is not a make file that is created after configure. I have someone helping with that.
On the test server, ImageMagick is installed and it happens on all files.

Usually it shouldn’t be necessary to build ImageMagick… most any distribution should have it in the package manager.

Anyway, my question remains: in the screenshot you have one working thumbnail. Does your answer mean that that file now no longer works, if reuploaded on that same server? You’d want to be looking at changes you’ve made between then (when it did work) and now, in that case.

I will try to install ImageMagick using apt-get.
The existing pictures are from when it was on Linux Mint 11 and I had to move everything to a new server in order to update it. The thumbnails were already there and still work.
I now am using Ubuntu 18.04.
I see what you mean now. I will try to upload an existing jpg to see if that works.
I just tried and existing jpg file to upload again and it still gives no thumbnail.

I am on my the Ubuntu 19.04 server and the is now loading and I see it on the info.php now but when I upload a jpg, it does not give a thumbnail. Any suggestions?

This is a new setup and thumbnails do not work.

OK, so on this server that you’re showing the phpinfo output of, do you have Omeka configured to use the “Imagick” thumbnailer?

How do you do have omeka use the imagick thumbnailer?

yes I have fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_Imagick”

There are instructions in the manual.

yes I have fileDerivatives.strategy = “Omeka_File_Derivative_Strategy_Imagick” but I can try again


The screenshot of the config you sent doesn’t include the relevant “strategy” line.

One of these things is not like the other…

For your setup, the line should read

fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_Imagick”

Thank you for your help, that worked.