No Editing after Omeka S Upgrade


#1

My users observed that three of their pages were not displaying unless users were logged in (to the public they gave “Entity of type ‘Omeka\Entity\Media’ for IDs id(2495) was not found” messages, with stack trace details, on each of the three pages). This seemed as good a time as any to update the site from 1.0.1 to 1.4.0, but after doing the update I find that pages cannot be edited—all Add New Block options have grey plus signs and cannot be clicked, and the Add Attachment button does not work. I went through the update steps a second time with the same result. Has anyone else encountered (and fixed) this behavior?


#2

Can you show a screenshot of the problem?

This sounds like an issue with CSS or Javascript… it could be just something fixed by clearing your browser’s cache, though caching should be getting reset automatically on an upgrade like this.


#3

This is what we get when we attempt to edit one of the three pages whose errors prompted this upgrade attempt. Only the text fields, the View button, and the Save button work—even Cancel does nothing—and clearing caches or changing browsers make no difference.


#4

We’ve also tried updating from 1.0.1 to 1.1.1 with the same result as the screenshot for 1.4.0.


#5

The gray plus signs are what those buttons normally look like, so I don’t think that’s related to anything.

There’s definitely something off with the styling, though, as the main section is drawing under the sidebar, which shouldn’t happen.

Is there anything being output in your browser’s Javascript console? (Often this is accessibile by pressing Ctrl+Shift+J, or Command+Option+J on a Mac.)


#6

Thanks for the tip: The Java console gave me the info I needed. Java wanted to download additional components, which it could not do from our isolated test network. Once the test server had a public IP address, normal behavior was restored.

Now I can go back to troubleshooting the main problem, which I’ll address under a separate topic.