NGram Plugin--No Results

Greetings all. I’m very intrigued about the possibility of running an Ngram analysis on my omeka site. I’m running:

  • Omeka 2.5
  • PHP 5.6.25 (cgi-fcgi)
  • MySQL 5.6.33

The NGram plug-in installation went fine as far as I can tell–message said it installed.

I’ve tried to set up about ten different corpora on the site, but after I click “Add Corpora” the little box on the right hand side of the resulting screen indicates that I have 0 items in my pool and 0 items in my corpora.

Also (strangely), I’m not asked to validate any items. Instead, the green validation button is grayed out and reads “Items Validated.”

I’ve confirmed that the searches work from the URL line, but here’s an example of one:


Basically, this search returns more 4000 results when done from the Advanced Search screen, and if I click on “Browse Search Results” on the NGram plug-in screen (just under “Search Query”), the search works perfectly. But still no items to validate and nothing in the pool.

My sequence element is “Date Issued” which is a consistently non-empty field. I used Sequence Type=Date by Year.

I have a feeling that I’m just doing something wrong…but I’m not sure what. Any suggestions or corrections would be most appreciated.


This happens when none of the search items are described by the corpus text element you selected when configuring the plugin. If none of the items have the text element, no ngrams can be generated. This is probably why the item pool count is zero.

Thanks for the reply, Jim. I admit to being perplexed about how none of the search items could fail to be described by the corpus text element I selected. My corpus text element is “Title” and all of my records have a title.

I’d love to see an example of the ngram plugin working on an omeka site. Maybe that would help me sort this out…

Thanks in advance for any additional assistance.


I think the best way to troubleshoot this is to reproduce the query on the advanced search page but add the corpus text and sequence elements to the “Narrow by Specific Fields” section using the “is not empty” search type. So, in your case, set your range as before and narrow by “Title: is not empty” and “Date Issued: is not empty”. If there are no results then none of your items in range 1-5000 are described by the corpus text and sequence elements. If there are results then there’s likely a problem in the plugin.