Neatline Warning appears in dashboard and Public View


#1

Hello Forum:

I’m using Omeka Classic 2.6.1 (byrononlineproject.com) and I have three Neatline exhibits. On the Neatline admin page, where the exhibits are listed, I’ve received the following warning next to the Exhibit named " Mapping Byron’s Mediterranean Letters and Childe Harold’s Pilgrimage I-II: By the Numbers:

Warning : Declaration of NeatlineRecord::save() should be compatible with Neatline_Row_Expandable::save($throwIfInvalid = false) in /home/byrononl/public_html/plugins/Neatline/models/NeatlineRecord.php on line 10

I would like to resolve this issue because the exact text of the warning appears in the Public View of the Dublin Core of letters collected in the exhibit named " [Mapping Byron’s Mediterranean Tour (1809-1811): The Letters]

Thank you, and
be well …Paul


#2

Hi Paul,

I’ve added this error to an issue reported on our github pages. We thought we had corrected this as of 2.6.1, but you’re on the latest release and are still seeing it, so apparently it’s not fixed in all cases. I’ll see what the developers have to say.

Thanks,
Ronda


#3

Aside from a possible fix to Neatline, you’re seeing that error because you enabled error display (the SetEnv line in the .htaccess file at the root of your Omeka install). If you comment that line out the warning should no longer be visible.


#4

Thank you, John, for the reply. I am a novice at programming. Could you give me the code that I need to “comment that line out?” Or, do I simply delete the line?

I appreciate your help more than you can imagine.

Be well …Paul


#5

You comment out a line in an .htaccess file by putting a pound sign at the front.


#6

Hi John:

Here is the line 10 with the pound sign at the front:

class NeatlineRecord extends Neatline_Row_Expandable

 implements Zend_Acl_Resource_Interface

The addition of the # sign produced an X in the left margin of line 11

Now, in my Omeka admin (Neatline, Browse Exhibits) I get this warning:

Parse error : syntax error, unexpected ‘implements’ (T_IMPLEMENTS), expecting end of file in /home/byrononl/public_html/plugins/Neatline/models/NeatlineRecord.php on line 11

Thanks, and Be well …Paul


#7

Heya John:

I reread your directions, found the .htaccess file and added the # sign at the SetEnv line. The warning has disappeared. Thanks again and Happy New Year.

Be well …Paul