Neatline and WMS

I have just installed Omeka on an Ubuntu server. I’m trying to use the Neatline plugin to create a map. No matter what I do, I can’t get a WMS to work under the Neatline exhibit settings. Once I fill out the WMS server and layer names, neatline will no longer display anything. I’ve searched online, but can’t find any fix for this.

Ok, so after looking at what neatline is rendering, I’m seeing that the issue with displaying a WMS seems to be related to the bbox that Neatline is including in the URL. This is true for all WMS that I have tried. If I manually alter the bbox in the inspector window, it will display. Any thoughts?

Are you attempting to:

  1. use a WMS layer as the base map in a NeatLine exhibit? if so, that’s under exhibit settings, and it affects everything on the map - so if something goes wrong, you won’t see anything.


  1. use a WMS layer as an overlaid image? that’s under “Style” in an individual record within a NeatLine exhibit, and it only affects that record - you should still see the basemap.

Also, did you remember to fill in the “layer” field? even if you’ve included the WMS url, Neatline needs to know which layer of that map to pull (this applies to both 1 and 2).

These are two things that have consistently tripped me up, so I hope this helps and it isn’t truly a bug!