Mirador error: SyntaxError: Unexpected token < in JSON at position 0

Hi everyone,
I used Omeka S with my college.
When I used Mirador for viewing images the plugin show me this error in Chrome: Mirador error: SyntaxError: Unexpected token < in JSON at position 0, when I used a Safari browser show me this: SyntaxError: The string did not match the expected pattern.

Only Mirador show me this problem because UniversalViewer works without problems.
This page for example: Natura Naturata · Le piante · Unife Virtual Heritage

Thanks!

Hello Matteo,

I took a look and it seems like the problem is that the URL https://virtualheritage.unife.it/iiif/1/4104/info.json does not exist. However, these ones work: https://virtualheritage.unife.it/iiif/3/4104/info.json https://virtualheritage.unife.it/iiif/2/4104/info.json

I think that this means that Mirador is trying to load IIIF resources using v1, but your IIIF module only supports versions of the protocol 2 or higher.

What versions of the Mirador Viewer and IIIF Server modules are you using?

Thank you for your response.
The version of IIIF server is 3.6.5.3 and the version of Mirador is 3.3.7.15.

What do you recommend that I do?

Thanks!

My guess, the link to your manifest is wrong.
I checked the page:

the link to the manifest is set to:
https://virtualheritage.unife.it/iiif/2/set/4103

but it should be: https://virtualheritage.unife.it/iiif/2/4103
Then I can see you scan e.g. with universalviewer

Really thanks!

But how can I integrate the correct manifest in the Mirador module?
Sorry but I don’t understand… :disappointed_relieved:

Could you switch to universalviewer just for testing? Then you could proof if there is an error or misconfig in the iiifserver. Otherwise the error is caused by mirador.

In this page (Browse page) I can see Mirador and UniversalViewer without problem, but if I insert the form in any page, it reports the problem to me.
Example: Botanica · Benvenuto · Unife Virtual Heritage

The example page is really a “page”, or? Not a item-show.phtml template.
Did yo try to add other manifest into your example

The modules are all up to date I assume? Unfortunately I do not really know how to find the error either.

Yes the page is part of the original site and yes by inserting other manifest Mirador works without problems.

I tried working on the IIIF server module and now I get this screen and not the images.