Memcache issue with Doctrine


Is there a place in Omeka S configuration where setting Doctrine configuration?

I get this error message:

Warning:  Memcache::connect(): Can't connect to, Connection refused (111) in /omeka-s/vendor/doctrine/orm/lib/Doctrine/ORM/Tools/Setup.php on line 133

Indeed, extension_loaded('memcache') seems to return true whereas no memcache service is installed. Has someone an idea to solve this problem which has recently appeared?

I’ll look into this. Doctrine tries to automatically determine what caching is supported on the system and use it automatically. It does seem a little silly that it takes simply the presence of the memcache extension as a sign it should automatically try to use it, given that the server is needed also.

Setting the config key ['entity_manager']['is_dev_mode'] to true in your local config should stop this error. Removing the memcache extension from your PHP install will fix it also.

We don’t have a way to configure Doctrine’s caching currently, so we’ll have to add one to fix this better. I’m of the opinion that Doctrine really shouldn’t be auto-chooising memcache (or redis, which also needs a running server), but that’s the current behavior.

1 Like

It works well, thank you for your quick answer! :slight_smile:

I suppose my server admin has installed Memcache PHP extension recently, making this bug to appear.

I agree with you for Doctrine auto-choosing, but I’m not sure this error has many time been encountered. Users who install Memcache PHP extension probably want to use it in Doctrine.