Item Thumbnail No Image Preview

I’m not getting a thumb view on Item uploads. I can see image preview on media page, but not on any other view.

What are the current settings in your local.config.php?

I don’t have a way to check file path in general settings. I think that was in Omeka not Omeka S.

My settings seem fine, I guess:

     return [
    'logger' => [
        'log' => false,
        'priority' => \Zend\Log\Logger::NOTICE,
    'http_client' => [
        'sslcapath' => null,
        'sslcafile' => null,
    'cli' => [
        'phpcli_path' => null,
    'file_manager' => [
        'thumbnailer' => 'Omeka\File\ImageMagickThumbnailer',
        'thumbnail_types' => [
            'large' => ['constraint' => 800],
            'medium' => ['constraint' => 200],
            'square' => ['constraint' => 200],
        'thumbnail_options' => [
            'imagemagick_dir' => null,
    'translator' => [
        'locale' => 'en_US',

The file_manager[thumbnail_options][imagemagick_dir] setting of null you have just tells Omeka to try to automatically figure out where ImageMagick is installed.

If you’ve got it in a nonstandard place or your server is set up so the PATH isn’t exposed to PHP (common in FastCGI or FPM setups), then Omeka can’t guess its location and you need to provide it manually (as in Classic, the value of that setting should be the path to the directory where the convert binary is installed).


  • I’m not sure how to locate appropriate directory where so called “Image Magick command” is stored. I see where images are being stored under file, and I located ‘application/src/File/Thumbnailer’ directory that has several .php files for image magick "stuff."I haven’t touched any application files, so i would assume all files should be placed as intended.
  • can you model the actual value please. I tried path above as value but didn’t change anything. In documentation, for example, there are backslashes and the path is forward slash (or maybe this doesn’t matter).

The ImageMagick path isn’t anything within Omeka, it’s the path where ImageMagick is installed on your server (assuming it is installed).

A common path is /usr/bin, but to be sure, just run which convert on the command line. (Or ask your web host, if you’ve got one.)

I see that it is installed on server (I use reclaim hosting and they document they include under “/usr/bin”). I added the following, uploaded a new image, but still nothing:
‘thumbnail_options’ => [
‘imagemagick_dir’ => ‘/usr/bin’,

Hmm, okay.

Can you enable logging (set log to true at the top of that config file)? Error messages will be logged to logs/application.log (make sure that file is writable by the server).

You should get a logged message when you upload a file explaining why we couldn’t make a thumbnail out of it.

I enabled true and added a new image, but the application.log file is empty

Did you make the log file (logs/application.log) writable? If you turn on logging but the log file isn’t writable, nothing will get logged.

yes, just logged back in now and a few errors were in there, but looks like file size on upload not my issue

That’s certainly strange.

Well, you can try switching the thumbnailer to not use ImageMagick (change the value of the thumbnailer line to Omeka\File\GdThumbnailer). That will use PHP’s built in image processing support. The downside is that it works on fewer file types (mostly standard images like GIF, JPEG, PNG).

Without any error messaging there’s not a lot we can really do to diagnose the ImageMagick problem.