Issue with Imagemagick not producing thumbnails from PDFs

Hi all,

Running into an issue that I can’t seem to track down. I am not getting thumbnails generated from the PDFs I’m attaching to items:

A couple notes:

  • I’m running this on Reclaim Hosting, in Omeka 2.x.
  • I’ve ensured that the ImageMagick path is correct and working.
  • I’ve set the background.php.path to the correct path (used when I did a CSV import)
  • I am attaching PDFs using the Dropbox plugin.
  • For testing, I tried a normal “Add Item…” workflow and attached a single file to upload, but ran into the same issue.

Thanks ahead of time for any pointers!

That actually looks like it’s producing thumbnails but just of pure white. Have you looked at the other thumbnail sizes to see if they look any different?

Also, can you give:

  • The specific version of Omeka you’re using
  • An example PDF that doesn’t work

The thumbnail sizes don’t appear to be different. I just tried a test item with a JPG screen shot, and it worked fine. I also just tried a single PDF (instead of using Dropbox) but no luck there, either.

I’m on Omeka 2.5. Here’s a sample PDF:

The images in that PDF look like they’re in JPEG2000 format, so it might just be that your installation of ImageMagick doesn’t have JPEG2000 support. ImageMagick actually usually just uses Ghostscript to read PDFs, so that is probably what really needs JPEG2000 support for this to work.

Some pdfs of mine generate thumbnails fine and some have the generic box.

I’m using 2.6.1

PDF doesn’t generate thumbnail :

PDF generates thumbnail:

I’m having a similar problem with PDF Thumbnails.

I was using a generic Ubuntu 18.04 LAMP stack, but then I uninstalled both ImageMagick and Ghostscript, then built them from source to try to make sure I had JPEG2000 support (using OpenJPEG).

Both showed OpenJPG as good to go in the configure output and nothing terrible happened when I complied either one.

I can run convert from the command line and split my PDFs into lovely JPGs.

Still no thumbnail when I import a file…

I suspect Ghostscript (9.26) is still my problem.

Any ideas or workarounds?


Had a look at the thumbnailer source code, which seems to call ImageMagick convert. So… if I can extract the PDF images at the CLI using convert, I’m wondering why the web environment fails.

Pretty sure my config.ini is set correctly, but will check.

So - tracked this down to a restriction in ImageMagick’s policy.xml file.

See this post over in the Omeka S forum for the solution.

Apparently it’s recommended to upgrade ImageMagick above 7.0.1-2 to plug the security concern the policy limit was implemented for:

I’m running ImageMagick 7.0.8-24. Thumbnails are looking good.