Issue setting up Iiif Search module

No, unfortunately we never figured it out, and the project we were working on was paused, so I’ve not had time to investigate further.

I got it working.

Within the IIIF Server module, there is a setting for entering the from and to base url. I needed to use these settings to update urls within the item manifest from http:// to https:// This setting fixed all of the urls in my item manifest except for the IIIF Search url.

I fixed the IIIF Search url by editing iiifSearch/Module.php. I used str_replace to replace http with https in the @id value within the handleIiifServerManifest function.

My solution is a little hacky, it would be cleaner to replace the @id value with the “to” setting int the IIIF Server module.

Hi @adehner, thanks for this update – I’m finally getting around to looking at this problem further.

So, to confirm, in the module.php you changed the http:// in the URLs on lines 89, 91, 98, and 101 to https:// ? I tried that and the search box in my viewer disappeared completely. I’m now seeing an https URL for the search in my manifest (, but I’m still getting the same error if I navigate to that URL.

I wasn’t having issues with any of the other manifest URLs, so I didn’t change the to/from the IIIF Server module, but maybe I need to do that too? Did you simply put “https:” in the to/from fields for the IIIF Server?


Hi all,

I’ve realized that my issues are a conflict with the Doman Manager module (we’ve had this issue with other modules), so I need to either find a workaround, or identify an alternative solution to Domain Manager, which appears to mess with the routing used by other modules.


This topic was automatically closed 360 days after the last reply. New replies are no longer allowed.