Installing Plugins on Ubuntu Terminal

Hello! I was able to download the CollectionTree plugin through my Ubuntu terminal. It is showing up in the appropriate folder on the server, however, when viewing my plugins on my Omeka site, the CT plugin does not show up. Can anyone help point me in the right direction as to what I’ve done wrong?


My first guess is a permissions problem, where the server doesn’t have any access to the files or folders.

Hi Patrick,

Thanks! My coworker and I also thought that was the problem but we have changed all of the permissions to the root user. The plug-in still is not showing up though. Can you suggest any other reasons as to why this won’t work properly? I can send you a screenshot of the terminal to a secure chat if that will help you.

That wouldn’t normally be what you’d want to do to fix a permissions problem, and it’s fairly likely to be counterproductive.

If the other plugins in the folder are working, the easiest thing to do to rule out a permission problem is to see what permissions those working folders have, and apply them to your new plugin (what user and group they belong to, and what read, write, and execute permissions are given).

Hi jflatnes,
I’m working with Erin to troubleshoot this issue, and we’ve tried everything permissions-wise to no avail. The user and group are the same as working extensions, and the permissions are actually looser than on working plugins (e.g. 664 vs. 644). We even tried with 777 but had no luck. The files have no extended properties, either.
Any other ideas as to why a plugin would fail to appear in the admin panel? Is there a way to register them manually in cases like this?

All the admin panel does to determine what to show is just list out what’s in the plugins folder, nothing more, so there’s no registration step to be done.

A plugin placed in that folder that’s just missing from the page is nearly always some kind of permissions problem. You said you checked extended properties, does that include checking for SELinux context on the folders (if you have SELinux enabled)?

Hi John,

How can one check to see if SELinux is enabled?

Here are the contents of the plugins folder:

CollectionTree is the one not showing in the admin panel.

I came across this thread where you suggested ls -Z to check SELinux context information, so we gave that a go but simply got ls output with single question marks before each item. Sorry I don’t have a screenshot from that - I don’t currently have direct access to the server.

UPDATE: Looks like the system doesn’t have SELinux

Just to confirm, there’s no listing for CollectionTree at all in the plugins page, correct? Not an error or something else being displayed?

Assuming that’s what’s happening, let’s for a moment go down to basics and make sure this is all in the right place in the first place. Does deleting the “Coins” folder, or moving it out to some other location, remove it from the plugins page (or cause an error)? In other words, make sure that you’re putting CollectionTree into the plugins folder for the installation you’re using on the web side.

There is no listing for the CollectionTree plugin on the Omeka admin panel, but it shows that it is included in the plugins folder on the terminal. I will try moving the Coins folder to a new location and see what happens.

Hi John,

We’ve done what you suggested doing but there have been no changes. COinS still shows up on the webinterface. Perhaps this issue comes down to a matter of security? Do you think that certain restrictions possibly in place by my IT Department would cause SELinux to not work properly?

If you’ve moved that Coins folder and aren’t seeing any change then basically there are 2 possibilities:

  1. You’re seeing really really aggressive caching, basically a “frozen” version of the site from some time ago. This is pretty unlikely and you’d pretty much immediately notice that nothing actually worked (like adding or deleting items) if this were the case.

  2. The folder that you’re working in isn’t actually the Omeka installation that you’re viewing in your browser. That is, the reason that the CollectionTree plugin doesn’t show up is that you haven’t actually put it into the plugins folder of the Omeka installation that you’re using. Whether that’s because it’s on the wrong server or simply in the wrong place, this is the most likely explanation that lines up with what you’ve reported.

i have met the same question.

Update: We have resolved this issue. There was some confusion due to files being held in another folder that we were unaware of. As a result, this caused the plugins to not be recognized on the admin panel. Make sure your plugin downloads are going to your /var/www directory.