Installation issue

I am trying to migrate 12 collections from a RHEL 6 to RHEL 7 server.

I have installed the collections on the new server. I installed RHEL 7. My apache install looks good. mod_rewrite is installed.

Apache version: Apache/2.4.6
PHP version: PHP 5.4.16
MySQL version: MySQL55 5.5.52

My phpinfo.php is working and the output below shows mod_rewrite installed (I put spaces on both sides so you could easily find it in the output).

My server test page works fine.

The problem I am have having is that the production server (RHEL 6) is still up and I am installing these on a new RHEL 7 server with a different name. That means the dns entries for the collections still point to the old server so I don’t know if I am having issues or not because I don’t know how to test the collection without dns working.

I can connect just fine off the server from a PC to my phpinfo.php file and apache default page on the server.

I can browse to http://servername/directoryname and I get an Omeka page that returns: “Omeka has encountered an error
To learn how to see more detailed information about this error, see the Omeka Codex page on retrieving error messages.”

I then went into the .httaccess file to try to troubleshoot. I removed the #.

SetEnv APPLICATION_ENV development

Nothing changes. No errors.

Is it possible for me to test the collection without having to change the dns entries to the new server?

Thanks for your thoughts and suggestions!

Rick Neal

phpinfo.php output below:

core mod_so http_core mod_access_compat mod_actions mod_alias mod_allowmethods mod_auth_basic mod_auth_digest mod_authn_anon mod_authn_core mod_authn_dbd mod_authn_dbm mod_authn_file mod_authn_socache mod_authz_core mod_authz_dbd mod_authz_dbm mod_authz_groupfile mod_authz_host mod_authz_owner mod_authz_user mod_autoindex mod_cache mod_cache_disk mod_data mod_dbd mod_deflate mod_dir mod_dumpio mod_echo mod_env mod_expires mod_ext_filter mod_filter mod_headers mod_include mod_info mod_log_config mod_logio mod_mime_magic mod_mime mod_negotiation mod_remoteip mod_reqtimeout mod_rewrite mod_setenvif mod_slotmem_plain mod_slotmem_shm mod_socache_dbm mod_socache_memcache mod_socache_shmcb mod_status mod_substitute mod_suexec mod_unique_id mod_unixd mod_userdir mod_version mod_vhost_alias mod_dav mod_dav_fs mod_dav_lock mod_lua prefork mod_proxy mod_lbmethod_bybusyness mod_lbmethod_byrequests mod_lbmethod_bytraffic mod_lbmethod_heartbeat mod_proxy_ajp mod_proxy_balancer mod_proxy_connect mod_proxy_express mod_proxy_fcgi mod_proxy_fdpass mod_proxy_ftp mod_proxy_http mod_proxy_scgi mod_proxy_wstunnel mod_ssl mod_systemd mod_cgi mod_php5

It’s very unlikely that DNS is the source of your issue.

Is your new server set up to respect .htaccess files? (This is the Apache AllowOverride setting)

Thanks for responding so quickly.

Yes. This is from the httpd.conf file

<Directory "/var/www">
  #Line below commented out for Omeka testing  rn 3-11-20
  # AllowOverride None
    AllowOverride All
  # Allow open access:
    Require all granted
</Directory>

If you can’t get the error display to work, enabling error logging is another option. Just make sure you have set the Omeka error log file to be writable by the server when you enable logging in the config file.