Install omeka s

I download beta version . I install Source code (zip) in my directory /var/www
The name of data base is omeka

In /var/www/config/database.ini.dist

user = "gus"
password = "mohicano22"
dbname = "omeka"
host = “localhost”
;port =
;unix_socket =
;log_path =

The address is

but I don’t see the omeka s

Someone can help me?

Those changes should go in database.ini, not database.ini.dist

thanks very much for your answer , but with the change, I can’t see the site…
I donwload now and use these link

can help me?

The completely blank page indicates that it isn’t getting to Omeka S at all – not a problem with the config files. I’d double-check that you have Omeka S installed in the correct place, and it’s all readable by the server.

thanks very much for your answer.
The page is not completely blanck

Only see these

I install in the directory



Yes, not completely blank, but it looks like a default page from the server. Did you check that /var/www and everything underneath it is readable by the server, and that that is the correct folder for your server’s configuration? These settings can vary from server to server. I suspect that the guidance you linked to works on Reclaim Hosting, but if you have a different provider, it could be different.

thanks very much. I install another server, but I have these error


can you see…

That’s progress.

I’m not 100% sure, but my first guess is that the PHP PDO module is not installed on the server.

Is there a guide for install under ubuntu server in mode terminal?
thanks very much Patrick

I see these
make sure that and are being loaded, either in the php.ini file or in their own .ini files inside /etc/php5/conf.d.

I think that PHP PDO module are installed

I use ubuntu, 16

do you have any idea?

I am having the same problem referenced here.

  1. Omeka classic is also installed on this server and running perfectly (connecting to mysql database fine)
  2. Running Ubuntu 14.04 LTS
  3. Everything in /var/www & below is readable by the server (other omeka install running fine)

When I enter the URL, the page responds with "The page isn’t working. is currently unable to handle this request. HTTP ERROR 500 reload ". However, when I change the password in the database.ini file to a WRONG password for the MySQL user then the URL page to omeka-s site responds with the following error:

Omeka S encountered an error

Service with name “Omeka\ModuleManager” could not be created. Reason: An exception occured in driver: SQLSTATE[28000] [1045] Access denied for user ‘suser’@‘localhost’ (using password: YES)


exception ‘PDOException’ with message ‘SQLSTATE[28000] [1045] Access denied for user ‘suser’@‘localhost’ (using password: YES)’ in /var/www/omeka-s/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
Stack trace:
#0 /var/www/omeka-s/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(43): PDO->__construct(‘mysql:host=loca…’, ‘suser’, ‘Crank-tape’, Array)
#1 /var/www/omeka-s/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php(45): Doctrine\DBAL\Driver\PDOConnection->__construct(‘mysql:host=loca…’, ‘suser’, ‘Crank-tape’, Array)
#2 /var/www/omeka-s/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(360): Doctrine\DBAL\Driver\PDOMySql\Driver->connect(Array, ‘suser’, ‘Crank-tape’, Array)
#3 /var/www/omeka-s/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(780): Doctrine\DBAL\Connection->connect()
#4 /var/www/omeka-s/application/src/Service/ModuleManagerFactory.php(87): Doctrine\DBAL\Connection->prepare(‘SELECT * FROM m…’)
#5 /var/www/omeka-s/vendor/zendframework/zend-servicemanager/src/ServiceManager.php(747): Omeka\Service\ModuleManagerFactory->__invoke(Object(Zend\ServiceManager\ServiceManager), ‘Omeka\ModuleMan…’, NULL)
#6 /var/www/omeka-s/vendor/zendframework/zend-servicemanager/src/ServiceManager.php(195): Zend\ServiceManager\ServiceManager->doCreate(‘Omeka\ModuleMan…’)
#7 /var/www/omeka-s/application/src/Mvc/Application.php(32): Zend\ServiceManager\ServiceManager->get(‘Omeka\ModuleMan…’)
#8 /var/www/omeka-s/index.php(17): Omeka\Mvc\Application::init(Array)
#9 {main}

I have confirmed that the pdo_mysql.ini and pdo.ini extensions are in the correct location on the server /etc/php5/mods-available) and LOADING correctly by running the following command:
php -r “new PDO(‘mysql:host=localhost;port=3306;charset=utf8;dbname=dbname’, ‘suser’, ‘passwd’);”

In the database.ini file, I’ve also tried changing the host= from localhost to IP Address to DNS name, to This does change the error from the HTTP 500 error to "Host ‘’ is not allowed to connect to this MySQL server. Followed advice of many Google,stackoverflow,geekstuff forums on fixing this error, but still no joy.

Please advise.
Many thanks for suggestions!

That’s the relevant piece of information. MySQL has its own set of users and passwords and privilege grants, and it’s telling you that the username/password combination you tried to log in with doesn’t work.

You’ll need to figure out (or create) the right credentials for your database to proceed.

Yes - I intentionally put the WRONG password in the database.ini file to see if I could get some sort of feedback from the page that only originally gives the HTTP 500 reponse error with no other error/logs. Once I put the CORRECT password in the database.ini file, then I get the mostly blank URL with This Page isn’t working HTTP 500.

I only used the incorrect password as part of the testing process to confirm that omeka is attempting to contact the mysql database and it indeed does. but when correct password is used, I don’t get any feedback.

Thank you for your response.

Okay, I see that in there now in your first message. Sorry about that.

Open up the .htaccess file and change this first line:

SetEnv APPLICATION_ENV “production”


SetEnv APPLICATION_ENV “development”

and see if that gives you something more in the way of an error instead of the generic 500.

Great: Thank you.
Now I get one line in the browser, which still doesn’t offer much, but perhaps you know what it means;

Parse error: syntax error, unexpected ‘.’ in /var/www/omeka-s/application/src/I18n/Translator.php on line 32

I also copied the line from the Translator.php file, line 32.

32 $translation = sprintf($translation, …$message->getArgs());

Many thanks for suggestions.

I have the same problem, I change the system, apache is ok, php is ok, driver for php ok but the error continued…

Omeka S encountered an error

An exception was raised while creating “Omeka\ModuleManager”; no instance returned


exception ‘PDOException’ with message ‘could not find driver’ in /var/www/html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
Stack trace:

These is the address


Your problem looks to be that you have a version of PHP that’s not recent enough for Omeka S. It requires PHP 5.6 or newer. We may be able to do something to make this error more friendly, but it’s telling you there’s a syntax error, but that line uses a syntax that was added in PHP 5.6. The most recent LTS version of Ubuntu, 16.04, has a recent enough PHP version.


On the other hand, your problem seems to be that you don’t have the PDO mysql driver installed on your system. You have PDO itself, but not pdo_mysql. Depending on your distribution it should be easy to install that extension, usually just by installing whatever package provides mysql support for PHP.

Excellent. Thank you for that discovery. I am running php 5.5.9. . . . so close. Will update. Cheers!

root@tehuelche:/etc/php/5.6/cli# php -v
PHP (cli)
Copyright © 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright © 1999-2016, by Zend Technologies

I have

Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-47-generic x86_64)