Images not rendering in Safari

I just noted a cross-browser problem with the display of images in Safari (v. 11.0.2). For certain of my exhibits, a few (not all) of the images are showing up at black boxes. When you click on the box, it takes you to the item, where the image also displays as a black box. This problem does not occur in either Chrome (v. 63.0.3239.84) or Firefox (v. 57.0.1).

I’ve tried going into the items, editing them, and re-saving them. This has had no effect on the problem.

Here are links to the effected pages:

You’ll note that on the third of these three pages, two of the images do show up normally and on the fourth, only a couple show up as black boxes.

Has anyone else experienced this issue? And if so, how did you fix it?



Looks like those pages are marked private. (Probably not related to the problem, but it just means we can’t see them.)

Hi John. Everything is public now, and the problem persists…only in Safari though.

Hi Mills,
I opened those pages in Safari and am able to see all of the images on every page just fine. It might be a caching issue with your browser?

Hi Megan. I tried clearing the cache…no luck. I tried going to the “website data” and deleting…still no luck.

Just to add complexity to the matter, the images load fine in Safari on my phone. Just not on my laptop.

Very strange. But as long as you can see the images, I won’t worry.