How to set a sub attribute (URI and label) of a Dublin Core property (eg:Rights) in CSV


#1

Hi team,

I would like to insert an URL with a label in the column Rights in my CSV, so what term that I can use in CSV to make the system understand this request? Currently I can only insert either the URL or the text. Anyone has idea about it? Thank you very much!


#2

In Omeka Classic I did use HTML <a> tag and it works but in Omeka S the html code does not interpret. I did choose the HTML set up in Media but it does not work as I want.


#3

The url is a media, so you can try to import media separately.


#4

One thing to do would be to map the Rights from your CSV to the Rights property and then under “Options” select “Import as URL reference”


#5

Hi Daniel,

I put a link in Rights but when choosing URL in Media Import option, there is no item in CSV file imported. However supposed that it worked. The display of URL can be long and not friendly to user. The URL should be embedded as a link with a friendly label.

In Omeka Classic, I put simply the below content in the Rights column of CSV then choosing an option of HTML in CSV import modules.

This work is licensed under <a target="_blank" href="https://creativecommons.org/licenses/by-nc-nd/4.0/" rel="noreferrer">Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License.</a>

If I import an item manually, I can use the attributes label and URL in the Rights property but I don’t know if we have a similar way to do it in CSV?


#6

Hi Mebrett,

It works in that way but the URL should be embedded under a friendly label. For example the URL is:
https://creativecommons.org/licenses/by-nc-nd/4.0/" rel=“noreferrer”. But I would like to embedded the URL under a friendly text as below:

This work is licensed under <a target="_blank" href="https://creativecommons.org/licenses/by-nc-nd/4.0/" rel="noreferrer">Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License.</a>

If I import an item manually, I can use the attributes of label and URL in the Rights property but I don’t know if we have a similar way to do it in CSV file?


#7

You can’t.

It is possible to improve CSVImport to add this feature, but what syntax would you use? The following one?

"http://my_URI_id"="my label";"ftp://another_URI"="other URI label"


#8

Hi Pols12,

Last time I used the HTML syntax in CSV file then Omeka can interpret but not Omeka S .


#9

Indeed, Omeka S uses standardized meta description. HTML syntax don’t describes the resource, so it should not be present in property values. Omeka won’t interpret HTML in property values, even <a> tags.

Links have a semantic, so they are handled by Omeka S.

However, I don’t think HTML is a good syntax to use in CSVImport to define links, because it is too complex and it would create the belief that Omeka S handles HTML.

What do you think about the syntax with equal sign I have proposed?


#10

Hi Pols12,

The proposed syntax looks good enough but I am not sure if it works like this. Ex:

There are two links in my words. One is “http://abc”=“this link” this link. Another one is “http://abcd”=“here” here.

Also, is it possible to have another tab opened when the link is clicked?

Thank you!


#11

You can have only one link per value. It’s possible to create a new DataType with a module, however, you should ensure your values still describe unique semantic information. This doesn’t seem to me possible with one sentence with two integrated links.

I have proposed to add a setting to allow to do this.


#12

I see! Thank you Pols12 very much!


#13

I noticed in the CSV documentation, it says you can set a label by “including the desired text after a space, for example: `http://example.com This Is The Label”.

However, when I tried this method, my import failed to create any items. In the log report, it looks like it literally tried to download the http:// address along with the text from the label in order to create the image. I clicked the wrench and set to import the data as a URL and not text, so I’m not sure what I am doing wrong.

Can anyone tell me? Thanks!


#14

What version of S and CSV Importer are you running? You may need to upgrade?


#15

Looks like I am on Omeka S 1.4.0 and the CSV is the 2nd most current at 2.0.0. I read that I can’t update to CSV 2.1.0 unless I upgrade Omeka S to 2.0.0, however it looks like my hosting server isn’t offering that most current Omeka S version yet.


#16

You may need to upgrade CSV (and core) in order to be able to use the space separation. If you’re on reclaim, that’s coming today.


#17

Thank you - I have just installed the latest version of both Omeka S and the CSV import module, and I’m still not able to create a label for the media link by using a space after the http link.