Help installing Omeka on institutional server (SUEXEC error)

Hi everyone,

(Excuse my ignorance in advance—I’m new to a lot of this!)

I’m trying to install Omeka on a server hosted by Stanford, but I can’t seem to successfully make it to step 6 of the instructions, when I log onto the admin portal and click “Install”. I believe I have everything set up properly, but I have two questions:

  1. I have a cgi-bin set up. Is this where we should upload the Omeka folder? Or, should we upload it to the general WWW directory?
  2. When I uploaded it to the general WWW directory and tried to log onto the admin portal, I got an “object not found” error. When I uploaded to cgi-bin and tried to log onto the admin portal, I got the following error message:


The SUEXEC program encountered an error while processing this request.
The Stanford CGI Service uses a modified SUEXEC to securely run cgi programs.
Consult the cgi documentation for further information and FAQ.

cannot get docroot information (/afs/ir/group/muslim-mh): chdir cwd

I assume the error is somehow related to the security mechanisms Stanford has put in place, but I am not sure. I have seen at least one successful Omeka site hosted by Stanford, so I know it’s possible, but I just keep getting stuck.

Any thoughts on how to proceed?

Thank you so much!

I think this is a situation where you’ll have to check with Stanford: it doesn’t necessarily look like it’s something that’s applicable beyond that.