Guest User plugin causes error to whole site

I just installed a new instance of Omeka and added the plugin Guest User. When I activate it I can no longer view the site, instead I see

Omeka has encountered an error

To learn how to see more detailed information about this error, see the Omeka Codex page on retrieving error messages.

I have tried enabling error messages but I still only get the message above. If I deactivate the plugin the site works again.

Any ideas how to fix this?

What versions of Guest User and Omeka are you running? (you should be able to find all of this in the System Information link in the bottom right-hand corner of the admin dashboard)

The latest of both, just downloaded them so guest user 1.1.1 and contribution 3.1.0

What other plugins do you have installed?

Just the ones that come with omeka by default, i tried deactivate everything but this one and it is definitely this one causing it. Tried changing the theme and that makes no difference.

And it’s happening on the admin side and the public, or just the public side?

Have you tried completely uninstalling Guest User (deactivate, click uninstall, go in, delete the folder) and then re-installing?

Yes I did uninstall and reinstall but will try again in case i did it in the wrong order or something.
By admin and public side what do you mean? I am logged in and then I go to view the site “live” but I am still also logged in…

Admin side is the part where you’re administering the website - the part you log in to see ( admin /whatever).

Public is the side of the site you can see whether or not you’re logged in ( / whatever )

Try activating error logging as well, and see what happens.

Okay that is what I thought you meant but wasnt sure how I could view the url without being at the url so was confused. admin is the dashboard, public site is the url in this meaning.

I tried uninstall and reinstall, didnt help.

I have tried activating error logging it apparently isnt working. I did exactly what it says to do to the .htaccess file but it looks the same and says to activate error logging.

I was actually talking about the second section of that page - with the "Edit your application/config/config.ini file and change the value of log.errors to true"

Okay, thanks. I had looked for that code earlier and that page and couldnt find it, found it now - but i am still getting the same exact page saying to enable errors

Is there anything in the error log - application/logs/errors.log ?

Yes! hurray
What should i be looking for, its a long list

Oh just realized at the very top it says
017-03-01T22:11:36+00:00 ERR (3): InvalidArgumentException: Could not find file css/guest-user.css! in /home/newberry/webapps/contribute/application/libraries/globals.php:1284

I dont know what to do with that info, dont know where that file should be…

Figured it out, it was exactly what it says - someone that file alone was not uploaded to the server.

Thank you for your help! :slight_smile:

Hi again,
I am now getting an error that says
ERR (3): InvalidArgumentException: Could not find file css/guest-user.css!

But I have checked and double checked and reuploaded this file to the css folder and I can see it there on the server. Any idea why the error says it cannot find it?

Permissions of the file are set to Read, should they be something else?

thank you!