Group Module Laminas Form Exception

Recently I have tried to install Daniel Berthereau’s Group module for Omeka S and I am having a little bit of a problem getting it to work properly.

The installation itself was not the issue, and it seems to work just fine on a Global Administrator-type user but it is the latter I am having issues with: it ONLY appears to function properly on a Global Admin. user and no one else.

In my experimentations I have created several new users of various roles (Researchers, Authors, Reviewers, you name it) through a GA user and assigned them individual groups. When I would sign in as one of these users, I would notice that they had no group assigned to them at all. Naturally, I tried a self-edit of the user but instead of the expected window I would get an exception:

I am not exactly sure how do I go about solving this yet or if this is even the right place to be asking for help, but I figured I might as well ask if anyone has had a similar issue in the past.

Thank you for your attention.

Sorry not to answer before, I skip some messages and notifications since some weeks.
I use this module for a site with some thousands of students, who are all Guest users. So they don’t have access to the admin part or the user form. So I didn’t check the module for other roles. Anyway, I fixed it in version

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.