Geolocation and HideElement reporting "This is not a valid plugin"


#1

Hi all. A coworker has been struggling with an upgrade to both Omeka and several plugins, and has called on me for help. Frankly, I don’t know Omeka that well, and I’m befuddled.

We have Omega Classic 2.6.1 installed, as well as Geolocation 3.0. When I load the Plugins administrative interface, both Geolocation and HideElements report “This is not a valid plugin”. Their files appear to be in the proper locations, and permissions look right (755 directories, 644 for files…matching other, functional plug-ins). Beyond that, is there anything I can examine or tweak, or any way to find out why they’re reporting as invalid?


#2

If the folders still have the prefix plugin-, deleting that prefix (so it’s just Geolocation and HideElements) should help.


#3

It’s not that…they’re named correctly in both cases. I’ve also tried removing Geolocation and downgrading to a previous release but, weirdly, the plug-in name and “invalid” warning never disappears from the plug-ins listing on the admin page (with the software deleted from the plugins directory and a freshly-cleared browser cache).


#4

The name will stay there because you have the plugin installed: the entry is there to indicate that Omeka can’t find the proper files for the plugin.

If the folder is there with the right name and the right contents, the usual issue is going to be permissions: you mentioned the modes but also check things like the owner and group of the folder and its contained files. If your system has SELinux that’s always a possible area for issues if the files have the wrong context set.


#5

Okay, I went and had a look. Owner:group assignments are also consistent with other plugins.


#6

Hmm. Could you post ls -laZ for the plugins folder? (And possibly for the top level of Geolocation also?)


#7
[foxonthe@davidson plugins]$ ls -laZ
drwxr-xr-x foxonthe foxonthe ?                                .
drwxr-xr-x foxonthe foxonthe ?                                ..
drwxr-xr-x foxonthe foxonthe ?                                Coins
drwxrwxr-x foxonthe foxonthe ?                                Contribution
drwxrwxr-x foxonthe foxonthe ?                                DCGE
drwxr-xr-x foxonthe foxonthe ?                                ExhibitBuilder
drwxr-xr-x foxonthe foxonthe ?                                Geolocation
-rw-r--r-- foxonthe foxonthe ?                                Geolocation-3.0.zip
drwxrwxr-x foxonthe foxonthe ?                                GuestUser
drwxr-xr-x foxonthe foxonthe ?                                HideElements
drwxr-xr-x foxonthe foxonthe ?                                SimplePages

and

[foxonthe@davidson Geolocation]$ ls -laZ
drwxr-xr-x foxonthe foxonthe ?                                .
drwxr-xr-x foxonthe foxonthe ?                                ..
-rw-r--r-- foxonthe foxonthe ?                                build.xml
-rw-r--r-- foxonthe foxonthe ?                                config_form.php
drwxr-xr-x foxonthe foxonthe ?                                controllers
-rw-r--r-- foxonthe foxonthe ?                                GeolocationPlugin.php
drwxr-xr-x foxonthe foxonthe ?                                languages
drwxr-xr-x foxonthe foxonthe ?                                models
-rw-r--r-- foxonthe foxonthe ?                                plugin.ini
drwxr-xr-x foxonthe foxonthe ?                                tests
drwxr-xr-x foxonthe foxonthe ?                                .tx
drwxr-xr-x foxonthe foxonthe ?                                views

Running on CloudLinux.


#8

OK, I don’t see any obvious problem there… the usual problems we’ve seen are things like permissions and folder names, or there being extra folders in the path or just missing files, things like that. None of that obviously seems to be the case here.

Basically, the “not a valid plugin” error happens when Omeka can’t find the “main” file for the plugin… that’s Geolocation/GeolocationPlugin.php in this example.

Can you post a screenshot of the Plugins page from the Omeka admin? Are any of the plugins listed twice, things like that?


#9

No, just the same error and circumstances with one other plugin.


#10

Okay…

You have another plugin/folder in your ls listing: DCGE. Even if that’s just a random folder and not a plugin, it should appear in the Plugins page in the admin.

Is the plugins directory that you’re making changes in the correct one? That is, the one that goes with the live installation you’re looking at?

Other than that, the only thing I can think of is that there’s permissions set with an ACL instead of standard Unix permissions, but that’s usually indicated with an extra character on the ls mode output which I’m not seeing here.