First login after install

Hello all,

Got Omeka installed. Got to the admin screen asking me for site details etc.
Completed these and now I’m directed to the below page / log file.

Any suggestions on what I need to do from here?

Db Profiler

The following queries were executed during the request:

[8.2015991210938E-5] SET SESSION sql_mode=‘STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_ENGINE_SUBSTITUTION’

[0.06327486038208] SELECT name, value FROM omeka_options

[0.0060768127441406] SELECT plugins.* FROM omeka_plugins AS plugins

[0.0075390338897705] SELECT omeka_sessions.* FROM omeka_sessions WHERE (((omeka_sessions.id = ‘tkdbo5c5i59kbg1snkosb3q0tp’)))

[0.01158595085144] SELECT items.* FROM omeka_items AS items WHERE (items.public = 1) GROUP BY items.id ORDER BY items.added DESC, items.id DESC LIMIT 3

Executed 5 queries in 0.088558673858643 seconds

Average query length: 0.017711734771729 seconds

Queries per second: 56.459743378509

Longest query length: 0.06327486038208

Longest query: SELECT name, value FROM omeka_options

You posted this in the Omeka S forum, but it looks like you’re describing an issue with Omeka Classic, so I’ve moved the post to the Omeka Classic Troubleshooting forum.

This is the “DB profiler,” which is a special output that’s enabled through the configuration file at application/config/config.ini. The relevant setting is debug.profileDb. It defaults to being disabled, but if you had edited the config file and set it to true, this is the kind of output you would see.

1 Like

Thanks!

Now getting the correct error message.

Any thoughts on where I might start looking here?

Request Data
Request URI: /
Params:
Array
(
[controller] => index
[action] => index
[module] => default
)
Session Data
Array
(
)
Server Data
Array
(
[REDIRECT_APPLICATION_ENV] => development
[REDIRECT_STATUS] => 200
[APPLICATION_ENV] => development
[HTTP_HOST] => omeka.XX.XX
[HTTP_CONNECTION] => keep-alive
[HTTP_CACHE_CONTROL] => max-age=0
[HTTP_UPGRADE_INSECURE_REQUESTS] => 1
[HTTP_USER_AGENT] => Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.193 Safari/537.36
[HTTP_ACCEPT] => text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.9
[HTTP_ACCEPT_ENCODING] => gzip, deflate
[HTTP_ACCEPT_LANGUAGE] => en-US,en;q=0.9,zh-CN;q=0.8,zh;q=0.7,fr;q=0.6
[HTTP_COOKIE] => _ga=GA1.2.1375566085.1579634523; e39c9a24527fc607601b951c1acd02e6=tkdbo5c5i59kbg1snkosb3q0tp
[PATH] => /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin
[SERVER_SIGNATURE] =>
Apache/2.4.41 (Ubuntu) Server at omeka.XX.XX Port 80

[SERVER_SOFTWARE] => Apache/2.4.41 (Ubuntu)
[SERVER_NAME] => omeka.XX.XX
[SERVER_ADDR] =>v
[SERVER_PORT] => 80
[REMOTE_ADDR] => XX.XX.XX.XX
[DOCUMENT_ROOT] => /var/www/omeka
[REQUEST_SCHEME] => http
[CONTEXT_PREFIX] => 
[CONTEXT_DOCUMENT_ROOT] => /var/www/omeka
[SERVER_ADMIN] => webmaster@localhost
[SCRIPT_FILENAME] => /var/www/omeka/index.php
[REMOTE_PORT] => 54140
[REDIRECT_URL] => /
[GATEWAY_INTERFACE] => CGI/1.1
[SERVER_PROTOCOL] => HTTP/1.1
[REQUEST_METHOD] => GET
[QUERY_STRING] => 
[REQUEST_URI] => /
[SCRIPT_NAME] => /index.php
[PHP_SELF] => /index.php
[REQUEST_TIME_FLOAT] => 1605569769.992
[REQUEST_TIME] => 1605569769

)
Routing Data
Current Route: default
Defined routes:
Route Name Matches Current Request Assembled with current params
default true
id false Could not assemble: id is not specified
page false Could not assemble: page is not specified
pluginInstall false Could not assemble: name is not specified
Cookie Data
Array
(
[_ga] => GA1.2.1375566085.1579634523
[e39c9a24527fc607601b951c1acd02e6] => tkdbo5c5i59kbg1snkosb3q0tp
)

This one’s very similar: it’s from setting debug.request to true in that same config file.

In general I’d recommend sticking with the defaults in that file unless you have a specific reason to change one.