First install - "Omeka has encountered an error"

New user. I’m installing Omeka to a dreamhost account (not one-click) and I’ve run through the installation instructions up step 6. I was getting detailed error messages, so I removed the # from SetEnv APPLICATION_ENV, I edited the config.ini file in two places: “debug.exceptions = true” and “log.errors = true” I set the permissions for the errors.log file 777. I wasn’t getting anything logged, but then used /install after the URL and I got the (below) error message: Any help would be appreciated!

Fatal error:  Uncaught exception 'Zend_Config_Exception' with 
message 'Your Omeka database configuration file has not been set up 
properly.  Please edit the configuration and reload this page.' in 
#3 /home/adasun3/ 
#4 {main}
  thrown in /home/adasun3/ on line 43

That looks like something isn’t quite right in the db.ini file. Double check that the info there corresponds to the username and password you set up for the mysql database (those are separate from your dreamhost login info)

Thanks for the quick reply. I just double checked and the information is all correct. The error message remains. Any other suggestions?

It’s a long shot that it’ll work, but is a simple and quick try: try the url /install/install.php Sometimes that resolves things.

I’ve also seen odd cases where including or not including the single quotation marks makes a difference, so trying the db.ini file both and without them is another thing to try.

Unfortunately, I’m still running into the same error after trying those fixes. No changes with single or double quotations marks. I realized when going back though phpmyadmin that the connection collation is still set to the default utf8mb4_unicode_ci. The setting can’t be changed (I assume because this is running wordpress). Could this be the issue?

That error only gets printed if the “host” line in the db.ini file is empty or left at the default, all Xs.

Are you sure everything’s right in db.ini? Could you be looking at the wrong file?

Checked and double-checked. I’m going to do a complete reinstall to see if I get the same error.