File Upload Error on Screenshots

Good morning, when I try to upload screenshots, I receive this error

  • The uploaded file exceeds the upload_max_filesize directive in php.ini

The file size is smaller than the max filesize we have set (4.5 mb vs 10mb).

I’ve tried uploading as .png and as .jpg and neither seem to work.

I can upload other file formats, and .jpgs that don’t derive from screenshots.

Any ideas?

Updating that I can get smaller screenshots to load (1-2mb) ,but even with increasing our max size to 20mb or 30mb, I can’t get a 4.5mb screenshot to load.

Can you share the information from the “System information” link (it’s at the bottom of every admin page). That page includes the current settings of all the relevant PHP settings for file upload limits.

If the values reported there don’t match what you changed in php.ini, make sure you’ve made the setting correctly in the right file. Another common issue is that typically to make php.ini changes take effect you need to restart Apache or PHP.

ahh, okay, so this doesn’t seem to match even the 10mb:

Omeka S
Version 2.1.0
Version 7.2.24
SAPI fpm-fcgi
Memory Limit 500M
POST Size Limit 8M
File Upload Limit 2M
Garbage Collection Yes
Extensions bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, json, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, Reflection, session, SimpleXML, sockets, SPL, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, zlib
Server Version 8.0.17
Client Version mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
Version Linux 4.18.0-193.14.3.el8_2.x86_64 x86_64

With an “fpm-fcgi” PHP installation like this, you usually need to restart/reload the PHP-FPM process after changing php.ini settings.

Thanks - turns out we weren’t restarting the fastcgi. Thanks for your help!

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.