Exhibits not working after migrating from version 1 to version 2

We recently migrated our instance of Omeka from version 1 to version 2 and are having issues with our exhibits not working. On the user end they just go to a page that says “The nsudigital.org page isn’t working
nsudigital.org is currently unable to handle this request.

We are also unable to add new photos since the update. Any idea what could be going on here and how to fix it? I’m at a loss and very novice to working with Omeka so any help is welcome.

Can you tell us what version of Omeka you were running (1? 1.5?) and what you upgraded to? And what version of Exhibit Builder you’ve upgraded to?

We were running version 1 and upgraded to version 2. Our version of Exhibit Builder is 2.1.1.

The Error has something to do with our Exhibit pages. When I go into edit them, it just goes back to the 500 error.

Can you give more detail on the Omeka version? 2.0, or some more recent version?

You can also just send the contents of the “System Information” page which will include the Omeka version and the versions of all the plugins.

we recently upgraded from Omeka 1 to Omeka 2.

Where do I find the system information page?

system information page:

Browser Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
Role super
Omeka 2.4.1
PHP 5.5.38 (cgi-fcgi)
OS Linux 3.2.61-grsec-modsign x86_64
MySQL Server 5.6.25
MySQL Client mysqlnd 5.0.11-dev - 20120503 - $Id: 15d5c781cfcad91193dceae1d2cdd127674ddb3e $
PHP Extensions
Regular bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, filter, ftp, gd, gettext, hash, iconv, imagick, imap, json, libxml, mbstring, mcrypt, mhash, mysql, mysqli, mysqlnd, openssl, pcntl, pcre, PDO, pdo_mysql, pdo_sqlite, posix, pspell, Reflection, session, SimpleXML, soap, sockets, SPL, sqlite3, standard, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend OPcache, zip, zlib
Zend Zend OPcache
Coins 2.0.2
CsvImport 2.0
DigitalObjectLinker 1.0
DocsViewer 2.0
Dropbox 0.7.1 (inactive)
ExhibitBuilder 2.1.1
FacebookComments 2.0.0
LcSuggest 2.0.1
Lcsh 1.1
PdfSearch 1.0 (inactive)
PdfText 1.0.1
SimpleContactForm 0.5
SimplePages 3.0.8
archives 2.0 (current)
berlin 2.1.3
default 2.1.1
gypsy 2.0
oahe 2.0
seasons 2.1.6

So, those versions are a little odd.

That’s a very recent version of Omeka, but a very old version of Exhibit Builder. As a first step try updating Exhibit Builder to the most recent version from its addons directory page.

I did delete our old version of Exhibit Builder and added the new one. Still no fix. Still getting the same error. Anything else I can try?

We do have our own custom templates, could anything with the cause these issues with the migration.
This is one of our sites. Just so you can see what is happening:


If you click on any of the subpages it just takes me to a dead end.

Okay. Try following the “Display Error Messages” instructions from this page.

What we’re looking for is to turn this generic 500 error into an actual error message that we can troubleshoot.

Ok. Did it. THis is the error I get:

Fatal error: Call-time pass-by-reference has been removed in /home/noruni/nsudigital.org/themes/oahe/exhibit-builder/exhibits/show.php on line 22

It does look like there’s a problem with your custom “oahe” theme, in particular the exhibit-builder/exhibits/show.php page on line 22.

Any Exhibit Builder custom view from version 1 won’t work correctly with the new Exhibit Builder anyway. What does that particular custom view do differently? A good first step would be to just move that file out of the way to some other folder so it’s not used and the default view is used instead. If you still need to have some custom theming of the view, you can re-make that file based off of the current Exhibit Builder exhibits/show.php view.