Exhibit pages not showing as active in the navigation


#1

Hi,

I have taken over a site and there are two pages on the site that are created using the exhibit builder plugin.
These pages are present in the homepage main navigation.
When I access these pages they do not show as active in the navigation menu (the navigation item does not highlight).
I’m assuming this is because the pages are generated via the exhibit builder plugin rather than via the simple pages plugin.
Is there a way I can get these exhibit pages to show as active in the main navigation?

Thanks.


#2

You can create links directly to exhibits in the navigation settings. You’ll need to add them as a navigation link, using the url for the exhibit’s first page.


#3

Thanks for your help.
I’ve linked to the page from the navigation bar and it clicks through to the page but still the navigation menu item does not highlight to show the page is active when on the page.
When I add ‘files with text’ and add an item the link doesn’t work when I click on it in the live page.

I inherited the site so I’m not sure why the page is buried in an exhibit when it appears to be a stand-alone page. My plan is to convert it to a Simple Page. The problem is I can’t get the layout I need using the Simple Pages editor.

Is there a way to override a Simple Page?
I’ve tried creating a .php file with the same name in the following directory:

themes/MTYTHEME/simple-pages/page

This doesn’t seem to work.

Thanks


#4

The link to the item does not work, or the link to the page (in the navigation) does not work on the live page?

If you want to add items to a simple page, you might want to take a look at shortcodes. Would that address your layout issues?


#5

Hi thanks, again for you help.
It was the link on the live page that wasn’t working but I need to dig into that more as I think the set up doesn’t seem to be standard. I’ve moved over to a Simple Page now anyway which seems more logical anyway (it’s for an ‘about us’ style page.

Regarding the layout, I had the HTML filter switched on in the security settings and so some of the tags I required were getting removed. Once I changed the filtering settings by adding my required tags to the white list I was able to achieve what I was after.

Note for anyone else in this position…in Settings -> Security -> HTML Filtering you not only need to set the tags you want to allow but also the attributes associated with the tags.

Thanks again.