Exhibit Image Annotation plugin

Does anyone have any experience getting the above mentioned plugin to work? We’ve installed it but can’t seem to upload an image.


You have to have the image already as part of an item. This screencast demonstrates the plugin step by step.

She is using version 2.5.1. We are using 2.6. The list of images does not populate once I click on add image as in her example.

Although I was using 2.5.1 when I made the screencast, the plugin still works on the same installation now that I have upgraded to 2.6

Have you tried re-uploading the file to the item, in case there’s an issue with the file? Does it generate a thumbnail properly for the item (before even getting to exhibits)?

Yes, all thumbnails appear properly. I have several different file types including jpg. I uploaded a new image to an item but still it won’t populate.

So the breakdown in functionality is between when you add the item to the block in Exhibit Builder and click the “load image” button?

Could you try turning on error logging, go through the whole process (including add the item to the block) and see if it anything shows up in the log?

I turned on the error logging and tried it again. No error is appearing in the log…any ideas?

I can’t reproduce this. There may be a JavaScript error. Are there any error messages in your browser’s debugging tool? Search how to open your browser’s debugging tool and repeat the steps you took. If there’s an error you’ll see it in the console.

Another question: do you get the same results when editing a “File” layout? When adding an item do you still see no items to attach?

I am unable to add any of the blocks. In other words, no options appear when I add a block. I can’t add text either. I have switched browsers, to no avail.

I am still unable to get any errors in the error log, either the Omeka or browser error log.

What happens after you select a layout and press the “Add new content block” button? You should see a new block under the “Content” header. If not, there’s something wrong with the Exhibit Builder plugin, not Exhibit Image Annotation.

If you walk us through what you’re doing step-by-step, perhaps we can pinpoint the problem more specifically.

Good question. Here is what I do - in three posts because I am limited to one per post.

Does this happen regardless of which layout you’re adding? For example, if you add a content block using the “File” layout, can you still not add an item?

yes, all blocks are nonresponsive. For example, if I add a gallery block, I can’t put text in the space offered.

Hi @anne1,

You mentioned you’re using Omeka 2.6. What version of Exhibit Builder are you using?

The version that came with the Omeka install. How would I tell what version it is? There is nothing in the plugin that I can see to give me this information.

Sorry, just found it - it’s version 3.3.3

So clearly the problem is in exhibit builder as it turns out. I am unable to add any blocks. Maybe I will reinstall it and see if that is the fix.