Exhibit builder not displaying featured exhibit

I’ve set an exhibit as ‘featured’. I’ve done this with other exhibits and the featured option displays the exhibit as the first one when accessed by viewers. It is not displaying correctly this time. I’ve done a work around by adding an A at the beginning of the exhibit title (I’m sorting alphabetically) but I would like the featured option to work properly. Ideas?