Errors when adding items/pages/exhibits

We are looking to use an Omeka installation to build our online archive. We’ve had an Omeka 2.0 put on our development server and deployed to test. It’s up and running and we can add some plugins and themes no problem, though it has compatibility issues due to it being an older version.

However one thing that is occuring is whenever I upload an item or ad a page, or save an edit to previously uploaded item I get an “Omeka has encountered an error”. It still uploads items if as if I navigate back they are there with all metadata attached.

In exhibit builder it lets me save the exhibit, gives the same error, but will not add a page when I try and get the error.

I’ve tried changing the .htaccess file so I can see error logs, but I didn’t get very far as there was a separate issue there.

I’m not sure where to go as I didn’t do the initial install, but I have done several in the post on localhosts. I’m doing everything through a SSH client too for the first time so navigation is taking some getting used to.


Unfortunately, without the error messages it will be tricky to diagnose, so that separate issue might be the thing for us to focus on first. You could also follow the instructions to display the errors in addition to logging them. That might get them visible for you to copy-paste here.

Thanks very much. Unfortunately I can’t seem to get that going either. It’s not letting me change the permissions of the errors log, or possibly just not the folder, I recall when first using Omeka 4/5 years ago having similar issues, but was using the graphical interface of Ubuntu rather than just an SSH client so some things were a little easier to fix for the novice.

Again, thanks for the reply. I’ll just have to plug away and work on building some collections rather than exhibits for now. My main IT contact is now gone for 2 months too.

Only thing I can add is that when doing a batch upload with dropbox plugin I had a communication error though it still upload 110 images.

Finally got to .htaccess file to change it. This is the error when saving an exhibit.

## #0 /var/www/plugins/SolrSearch/lib/solr-php-client/Service.php(669): Apache_Solr_Service->_sendRawPost('http://localhos...', 'add('addDocuments(Array)
## #3 [internal function]: SolrSearchPlugin->hookAfterSaveRecord(Array)
## #4 /var/www/application/libraries/Omeka/Plugin/Broker.php(157): call_user_func(Array, Array)
## #5 /var/www/application/libraries/Omeka/Record/AbstractRecord.php(295): Omeka_Plugin_Broker->callHook('after_save_reco...', Array)
## #6 /var/www/application/libraries/Omeka/Record/AbstractRecord.php(550): Omeka_Record_AbstractRecord->runCallbacks('afterSave', Array)
## #7 /var/www/application/libraries/Omeka/Controller/AbstractActionController.php(145): Omeka_Record_AbstractRecord->save(false)
## #8 /var/www/application/libraries/Zend/Controller/Action.php(516): Omeka_Controller_AbstractActionController->addAction()
## #9 /var/www/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('addAction')
## #10 /var/www/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
## #11 /var/www/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
## #12 /var/www/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
## #13 /var/www/application/libraries/Omeka/Application.php(79): Zend_Application->run()
## #14 /var/www/admin/index.php(28): Omeka_Application->run()
## #15 {main}

Please ignore. Though I don’t understand most of that, I figured the first line was that SOLr is messing things up. I removed that plugin and it’s working now. Apologies.