Error When Trying to Generate API Key

I seem to be unable to generate an API key using the Omeka API plugin. I keep getting an ‘error on form’ message and no key ever appears. Is there a setting I need to ask my host to adjust?

You should be able to generate API keys from the Users section of the Admin Dashboard - it should not require a plugin.

What version of Omeka are you using?

Hi. Thanks for your reply!

When I enter LivingLegacies as my label and then click the green button this is what I get:

And sorry yes, no plugin. My host said they’d ‘enabled API access’. And we are on 2.61.

Under Settings - API, is API enabled?

Yes ma’am. API is enabled.

Hi! I’m working on resolving this issue that Kelli has reported:

Attempting to generate an API key results in an error message “There was an error on the form, Please try again.”

API is indeed enabled. Tracing through the code, the error seems to be originating in the source code file application/controllers/UsersController.php, line 312:

Reading the code, it seems like there may be an issue with a CSRF (cross site request forgery, maybe?) token not being valid. Is there a way to reset the token or disable CRSF token generation?

I tried to create an API key in a brand new Incognito window, which creates a completely fresh session with no cookies or browser cache.

I’m testing this on the latest version of Chrome, and get the same results in macOS and Ubuntu Linux, with the same result.

Manny Rodriguez
LibraryHost Support

I still haven’t been able to reproduce this, so I’m thinking that an issue with your install is probably the most likely culprit. How did you do the upgrade? This problem could occur if you updated some but not all the Omeka files when you upgraded to 2.6.1 (in particular, if you missed the file admin/themes/default/users/api-keys.php).

This topic was automatically closed after 250 days. New replies are no longer allowed.