Error when trying Omeka Import

Greetings from Bahston!

Something is amiss when I use the Omeka Importer for Classic, giving


    Unable to Connect to ssl:// Error #0:

Zend_Http_Client_Adapter_Exception: Unable to Connect to ssl:// Error #0:  in /var/www/html/omeka/application/libraries/Zend/Http/Client/Adapter/Socket.php:235
Stack trace:
#0 /var/www/html/omeka/application/libraries/Zend/Http/Client.php(1073): Zend_Http_Client_Adapter_Socket->connect('ssl://mallhisto...', 443, true)
#1 /var/www/html/omeka/plugins/OmekaApiImport/controllers/IndexController.php(23): Zend_Http_Client->request()
#2 /var/www/html/omeka/application/libraries/Zend/Controller/Action.php(516): OmekaApiImport_IndexController->indexAction()
#3 /var/www/html/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('indexAction')
#4 /var/www/html/omeka/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#5 /var/www/html/omeka/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(105): Zend_Controller_Front->dispatch()
#6 /var/www/html/omeka/application/libraries/Zend/Application.php(384): Zend_Application_Bootstrap_Bootstrap->run()
#7 /var/www/html/omeka/application/libraries/Omeka/Application.php(73): Zend_Application->run()
#8 /var/www/html/omeka/admin/index.php(28): Omeka_Application->run()
#9 {main}

Searching around the error gives a lot of (oldish) results saying to check openssl is installed and enabled, but phpinfo() tells me that it is.

Importing the same with Omeka S fails, too.

So this smells like a problem with my laptop configuration, and I’m concentrating on that end in other fora, but I figured I’d ask here, too, in case you have quick insights into where I should look.

Miss you all much, and hoping things are going well there.


PS The culture I’m acclimating to requires me to say GO SOX!

Yeah usually this “error zero” business is about an SSL configuration issue: if I’m remembering correctly, it’s typically that PHP doesn’t know where to find SSL CA certificates on your machine. For whatever reason the errors reported from openssl are generally useless in PHP.

The correct path differs a bit from install to install, but you usually just need to set one of the SSL configuration options in php.ini. Either the path or file options is sufficient, it just depends on where your system puts them. This usually isn’t a problem on new-enough PHP that can run Omeka S, though, so it’s possible the issue is a different one.

Or, an even easier option: doesn’t have an SSL certificate, so you should be using as the start of the URL.

Heh. yep. http sans s made it go. silly error on my part.

I mentioned a problem with Omeka S, too, but appears to have been completely unrelated and is all good now (I missed installing imagemagick).

Thanks! Cheers to the dev table!