Error When Adding Files to Items

Hi There,
I cant upload files to items that i’ve been create before, i cant add image too


What version of Omeka are you running? What is your user role on the Omeka site? Are you able to add new items?

i’m using omeka 2.5.1 version, i’m the system admin and yes i can add new items

i’m using omeka 2.5.1 version, i’m the system admin and yes i can add new items

Is it with all files or only certain ones? (Is there a chance it could be a file size limit issue with your host?)

No issue with my host, after i upload the file it show error

"Omeka has encountered an error

To learn how to see more detailed information about this error, see the Omeka Codex page on retrieving error messages.

i try to remove (#) sign in the .htaccess to show the error message, but after i remove it, error 500 internal bla bla bla

1 Like

When you remove the # from #SetEnv APPLICATION_ENV development, your site returns a 500 error?

Have you tried activating error logging instead? (bottom of the linked page)

yes, i’ve try remove # my site have error internal server 500 error
after i activate error log this is the error

2017-12-08T01:56:44+00:00 WARN (4): Omeka_Storage_Adapter_Filesystem: Tried to delete missing file ‘original/f277bf94c1d00fef5bdf4434798e7273.pdf’.
2017-12-08T01:56:44+00:00 ERR (3): exception ‘Omeka_File_Derivative_Exception’ with message ‘Failed to execute command: -background white +repage -flatten -thumbnail .’ in /home/k6504535/
Stack trace:
#0 /home/k6504535/ Omeka_File_Derivative_Strategy_ExternalImageMagick::executeCommand(’ -background w…’, NULL, NULL, NULL)
#1 /home/k6504535/ Omeka_File_Derivative_Strategy_ExternalImageMagick->createImage(’/tmp/f277bf94c1…’, ‘/tmp/fullsize_f…’, ‘fullsize’, 800, ‘application/pdf’)
#2 /home/k6504535/ Omeka_File_Derivative_Creator->create(’/tmp/f277bf94c1…’, ‘f277bf94c1d00fe…’, ‘application/pdf’)
#3 /home/k6504535/ File->createDerivatives()
#4 /home/k6504535/ Job_FileProcessUpload->perform()
#5 /home/k6504535/ Omeka_Job_Dispatcher_Adapter_Synchronous->send(’{“className”:"J…’, Array)
#6 /home/k6504535/ Omeka_Job_Dispatcher_Default->send(‘Job_FileProcess…’, Array)
#7 [internal function]: File->afterSave(Array)
#8 /home/k6504535/ call_user_func(Array, Array)
#9 /home/k6504535/ Omeka_Record_AbstractRecord->runCallbacks(‘afterSave’, Array)
#10 /home/k6504535/ Omeka_Record_AbstractRecord->save()
#11 /home/k6504535/ Item->saveFiles()
#12 [internal function]: Item->afterSave(Array)
#13 /home/k6504535/ call_user_func(Array, Array)
#14 /home/k6504535/ Omeka_Record_AbstractRecord->runCallbacks(‘afterSave’, Array)
#15 /home/k6504535/ Omeka_Record_AbstractRecord->save(false)
#16 /home/k6504535/ Omeka_Controller_AbstractActionController->addAction()
#17 /home/k6504535/ ItemsController->addAction()
#18 /home/k6504535/ Zend_Controller_Action->dispatch(‘addAction’)
#19 /home/k6504535/ Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#20 /home/k6504535/ Zend_Controller_Front->dispatch()
#21 /home/k6504535/ Zend_Application_Bootstrap_Bootstrap->run()
#22 /home/k6504535/ Zend_Application->run()
#23 /home/k6504535/ Omeka_Application->run()
#24 {main}

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.