Directory Move / Web Address

Hello, I’m taking over an omeka server and making it public facing on the internet. I have had success with my Port Forwarding and A Record as it is fully functioning located at

However my problem is the /omeka at the end of the address. The library wishes to use the already long address without the need to type /omeka at the end.

This post is a question of how I get rid of the /omeka either by configuration change or directory move?

The end result should be

Just moving all the files up to the top level of the server should work, assuming there’s nothing already there (doesn’t look like there is).

I’m having no luck. I’ve figured out how to change the permission in the folder so I could move the files. I move the files and the site is all broken links. I move the files back and the site works again. I thought late last night that maybe all I had to do was move the index.php. No such luck. I keep making a change and putting it back.

I’m one step further now that I can move files without permission errors.

However i’m still in my same state with /omeka because I can’t figure this out.

Even reading the installation guide sets up failure because it recomends creating the omeka folder. I just don’t understand how to correct this seemingly simple problem.

My first guess about the broken links after you moved the files is that the .htaccess file in the root of Omeka. That’s something to double-check.

There is no htaccess file in the root of Omeka

That’s very likely the problem. .htaccess (note the dot at the front), is always a necessary part of Omeka. Some user interfaces hide dot files like .htaccess, so it’s easy to miss it in file transfers. Look around for a setting like “Show hidden files” or “Show dot files”. Make sure that those are visible, and that they get moved when you move things to the top level directory.

WOW, you sir are the Omeka Wizard!

Figured out how to show hidden files in ubuntu, moved the directory. Tested the site and it works.

Thank you!