Data Move/Upgrade issue


#1

Hi,
This is most likely going to be a confusing post, so I apologize.

Our instance of Omeka runs on Windows 2008 server. We are currently running Omeka 2.0.4. I am trying to move this instance from Windows to a VM running Ubuntu and upgrade to the newest version of Omeka. We have a lot of customizations that have been documented.

I am in the process of moving the data and files. This is what I have completed so far:

–Used phpmyadmin to move the data and the database users to the new server. (This has been successful);
–Moved the files from the old server to the new server (I can only access the front page);
–Tried to run the upgrade, but when I go to the admin site I receive the error of The requested URL /omeka-2.5.1/admin/upgrade was not found on this server.

Apache/2.4.18 (Ubuntu) Server at omeka-ubuntu.ad.uwp.edu Port 80

I am continually receiving this error. I’ve repeatedly checked the apache2.conf file as well as the .htaccess file and can’t figure out what I need to change or if this error means something else. Any ideas?

My second question is this the generally accepted way to complete this? I’m trying to use the doc here: https://omeka.org/codex/Moving_to_Another_Server

But it doesn’t really cover the upgrade part so I’m trying to use the upgrade doc.

Thanks in advance!

Jay Dougherty
Head of Library Systems
UW-Parkside Library


#2

Your process sounds fine from what you’ve said. When you say you moved the “files,” do you mean just the uploaded files, the files directory that is, or do you mean the whole install? Either can work, but it’s often easier to just start out with a clean copy of the new version when you’re trying to move both servers and Omeka versions simultaneously, just copying db.ini and other configuration files alongside the files directory.

Anyway, having the new server say “the URL is not found” probably means you’ve got an .htaccess/mod_rewrite problem on your new server. You mention checking the Apache configuration and the .htaccess file, so you’re thinking in that ballpark already. Things to check:

  • If you have RewriteBase set in .htaccess, did you change it to reflect your new location at /omeka-2.5.1/ ?
  • You’ve mentioned checking the Apache configuration, but make sure again that AllowOverride is on for the path where your site resides. A simple way to double-check that Apache is actually loading your .htaccess file is to just type some gibberish at the top of it: if it’s being loaded, then Apache will give you a 500 error when you try to go anywhere on the site.
  • Of course, make sure mod_rewrite is enabled (a2enmod or something similar, depending on the server).

#3

Thank you so much! The issue was that I didn’t have AllowOverride on. Thanks for the extremely quick response.