Custom Vocab: Option to suppress "eng" property

I am using the Custom Vocab module in Omeka-S 2.02.

Values selected from the pick-lists seem to appear with a little “eng” to the left, which seems to reflect the Language qualifier. This stands out on my show pages and raises unwanted questions.

I’ve tried not specifying the Language or entering “” for Language on the Custom Vocaubulary definition pages but neither of these helps.

Is anyone else seeing this? Does anyone have a tip for simplifying the display of custom vocab terms?


Hmm… I don’t think Custom Vocab should be setting anything for value language if you’re not setting a language in the vocab definitions. We certainly aren’t setting “eng” as a default, since it wouldn’t make sense for lots of users. You’re sure this is coming from Custom Vocab values, and that “eng” isn’t set on the configuration for the vocab(s) being used?

Thank you very much John. Indeed, the custom vocabulary did have the Language attribute set after all. Unsetting it and then re-assigning the property for the item did the trick.