CsvImport stops

I am no longer able to import items into Omeka (ver. 2.7); the import process begins as usual and then shows the status as Stopped, with no items added and none skipped.
There’s an Undo Import link, but that doesn’t work, so test imports are piling up.
When I turn on error logging, I see:
[CsvImport][#5] Stopped import or undo import due to error: Call to a member function getControllerName() on null

How do I fix this (and why did it start in the first place)?
Thanks!

Is there more to that message? Particularly, an indication of the filename and line number where the error occurred? It should be just after the part you’ve pasted here.

No, the entire content of the error log is:

2020-08-11T14:00:49-07:00 ERR (3): [CsvImport][#5] Stopped import or undo import due to error: Call to a member function getControllerName() on null

Line 2 is blank.

Here’s all I see on the import status page:


And “Undo Import” doesn’t do anything, so the failed attempts are all still there.

Thanks for your help!

OK…

Can you share what other plugins you have installed/active? (There’s a convenient list in System Information, linked at the bottom of every admin page.)

My immediate guess here is that the issue is another plugin, not CSV Import itself, that doesn’t work well with background jobs like the import. If you recently added a plugin, you could also just try deactivating it to see if that’s the issue.

Thank you!! It appears that the plugin “Item Duplicator” conflicts with csv uploads - once I deactivated the plugin, the import completed successfully!

I do use the Item Duplicator plugin, though, so hope this conflict can be resolved. In the meantime, we’re back in business!

Hello, @sbarnessckls and John.
Thanks for the information, and sorry for the very late reply.

As I don’t have CSV Imports working on my system, would it be possible for @sbarnessckls to substitute the new ItemDuplicatorPlugin.php file from GitHub into your installation and let me know whether the issue is now fixed?

Thanks.

1 Like

Thank you, DanieleB! I have installed the new version, and my test imports worked just fine while the Item Duplicator plugin was active!

The only remaining issue is that the previous unsuccessful attempts won’t undo, so they’re still listed. In this case, it’s only a test install, so I won’t bother to investigate removing them another way.

Thanks again for the fix - this is a very useful plugin!

Thanks to you for testing, @sbarnessckls ; I’m glad the issue was solved.

As for the failed imports: I would remove the records from the db itself, if they annoy you :wink: