CSV Import et DispatchStrategy

Hello
I’m using CSV Import and I’m always finishing with a beautiful " 504 Gateway Time-out" :
I remember, but maybe not, that it could deal with the configuration line :
‘Omeka\Job\DispatchStrategy’ => ‘Omeka\Job\DispatchStrategy\Synchronous’

But I can’t find the right option I have to choose :\

I’m on a mutualised web server with a short timeout configuration…

Thx for help
Nico

Yes, it’s related to the “Synchronous” setting. Having that there means that instead of running jobs in the background, they run during a web request, and are therefore subject to the normal timeout rules.

The “normal” configuration doesn’t have that line at all, you could comment it out or remove it. The default setting that will be used if that line’s not there at all is Omeka\Job\DispatchStrategy\PhpCli

Now, you may have used that setting because the PHP CLI isn’t available on your server in the first place, so you needed to use the Synchronous strategy for jobs to run at all. If that’s the case, then your only solution would be cutting up your CSVs into smaller chunks so they can import within the timeout. That, or changing hosts.