Contribution Confirmation Email Bug?

Hello,

My team and I have a site that uses contribution forms. Our front-end added some arrow for clarification when asking questions to the users–but when we are sent a confirmation email, we receive strange “encoding” issues? Is there something that can be done to change the symbol? Or have the symbol correctly displayed in the email? We have tried different browsers to no avail.

Examples attached~

Thank you!
tjo

My first guess it could be they changed the encoding of the page to add graphical arrows, thus messing up with the encoding of the form.
Possible solutions: apply a different encoding just to your form, or use icons instead of graphical arrows and restore the original encoding of the page.
Hope this helps.

I can’t reproduce the issue. If you’re comfortable modifying code, try this: open modules/Collecting/src/Controller/Site/IndexController.php in a text editor and add the following line immediately under $messagePart->setType('text/html'); (line #286):

$messagePart->setCharset('UTF-8');
1 Like

Not sure how to accomplish this–would they need to go into our repository and adjust a line of code? Is there an encoding option available via the Omeka dashboard? (trying to make this easily accessible for site maintenance in the future when part of our team is done working with us)–thank you for responding!

Fantastic~
We applied this to both the collecting Notification and Submission areas.
Our line of code was after: 275 & 323.
I just “found” the line of code you mentioned and placed after–both appear to be fixed.
For future patrons, we’re using Omeka S and Reclaim hosting.

Thank you so much!